summaryrefslogtreecommitdiffstats
path: root/dom/webgpu/tests/cts/checkout/tools
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webgpu/tests/cts/checkout/tools')
-rwxr-xr-xdom/webgpu/tests/cts/checkout/tools/gen_listings7
-rw-r--r--dom/webgpu/tests/cts/checkout/tools/gen_listings_and_webworkers8
-rwxr-xr-xdom/webgpu/tests/cts/checkout/tools/gen_version13
-rw-r--r--dom/webgpu/tests/cts/checkout/tools/gen_wpt_cfg_chunked2sec.json1
-rw-r--r--dom/webgpu/tests/cts/checkout/tools/gen_wpt_cfg_unchunked.json1
-rw-r--r--dom/webgpu/tests/cts/checkout/tools/server6
6 files changed, 20 insertions, 16 deletions
diff --git a/dom/webgpu/tests/cts/checkout/tools/gen_listings b/dom/webgpu/tests/cts/checkout/tools/gen_listings
deleted file mode 100755
index 6c25622423..0000000000
--- a/dom/webgpu/tests/cts/checkout/tools/gen_listings
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/usr/bin/env node
-
-// Crawl a suite directory (e.g. src/webgpu/) to generate a listing.js containing
-// the listing of test files in the suite.
-
-require('../src/common/tools/setup-ts-in-node.js');
-require('../src/common/tools/gen_listings.ts');
diff --git a/dom/webgpu/tests/cts/checkout/tools/gen_listings_and_webworkers b/dom/webgpu/tests/cts/checkout/tools/gen_listings_and_webworkers
new file mode 100644
index 0000000000..285df3657d
--- /dev/null
+++ b/dom/webgpu/tests/cts/checkout/tools/gen_listings_and_webworkers
@@ -0,0 +1,8 @@
+#!/usr/bin/env node
+
+// Crawl a suite directory (e.g. src/webgpu/) to generate a listing.js containing
+// the listing of test files in the suite, and some generated test files
+// (like suite/serviceworker/**/*.spec.js).
+
+require('../src/common/tools/setup-ts-in-node.js');
+require('../src/common/tools/gen_listings_and_webworkers.ts');
diff --git a/dom/webgpu/tests/cts/checkout/tools/gen_version b/dom/webgpu/tests/cts/checkout/tools/gen_version
index 53128ca2a0..2c17db1454 100755
--- a/dom/webgpu/tests/cts/checkout/tools/gen_version
+++ b/dom/webgpu/tests/cts/checkout/tools/gen_version
@@ -1,6 +1,6 @@
#!/usr/bin/env node
-// Get the current git hash, and save (overwrite) it into out/framework/version.js
+// Get the current git hash, and save (overwrite) it into gen/.../version.js
// so it can be read when running inside the browser.
/* eslint-disable no-console */
@@ -16,18 +16,13 @@ if (!fs.existsSync(myself)) {
const { version } = require('../src/common/tools/version.ts');
-fs.mkdirSync('./out/common/internal', { recursive: true });
-// Overwrite the version.js generated by TypeScript compilation.
+fs.mkdirSync('./gen/common/internal', { recursive: true });
+// This will be copied into the various other build directories.
fs.writeFileSync(
- './out/common/internal/version.js',
+ './gen/common/internal/version.js',
`\
// AUTO-GENERATED - DO NOT EDIT. See ${myself}.
export const version = '${version}';
`
);
-
-// Since the generated version.js was overwritten, its source map is no longer relevant.
-try {
- fs.unlinkSync('./out/common/internal/version.js.map');
-} catch (ex) { }
diff --git a/dom/webgpu/tests/cts/checkout/tools/gen_wpt_cfg_chunked2sec.json b/dom/webgpu/tests/cts/checkout/tools/gen_wpt_cfg_chunked2sec.json
index 1d13e85c58..123a06e9cd 100644
--- a/dom/webgpu/tests/cts/checkout/tools/gen_wpt_cfg_chunked2sec.json
+++ b/dom/webgpu/tests/cts/checkout/tools/gen_wpt_cfg_chunked2sec.json
@@ -1,6 +1,7 @@
{
"suite": "webgpu",
"out": "../out-wpt/cts-chunked2sec.https.html",
+ "outVariantList": "../gen/webgpu_variant_list_chunked2sec.json",
"template": "../src/common/templates/cts.https.html",
"maxChunkTimeMS": 2000
}
diff --git a/dom/webgpu/tests/cts/checkout/tools/gen_wpt_cfg_unchunked.json b/dom/webgpu/tests/cts/checkout/tools/gen_wpt_cfg_unchunked.json
index ffe06d5633..9e8dfe229d 100644
--- a/dom/webgpu/tests/cts/checkout/tools/gen_wpt_cfg_unchunked.json
+++ b/dom/webgpu/tests/cts/checkout/tools/gen_wpt_cfg_unchunked.json
@@ -1,5 +1,6 @@
{
"suite": "webgpu",
"out": "../out-wpt/cts.https.html",
+ "outVariantList": "../gen/webgpu_variant_list.json",
"template": "../src/common/templates/cts.https.html"
}
diff --git a/dom/webgpu/tests/cts/checkout/tools/server b/dom/webgpu/tests/cts/checkout/tools/server
new file mode 100644
index 0000000000..01e5a8a0c8
--- /dev/null
+++ b/dom/webgpu/tests/cts/checkout/tools/server
@@ -0,0 +1,6 @@
+#!/usr/bin/env node
+
+// Launch a server that runs tests server-side on demand.
+
+require('../src/common/tools/setup-ts-in-node.js');
+require('../src/common/runtime/server.ts');