summaryrefslogtreecommitdiffstats
path: root/dom/webgpu/tests/cts/checkout/tsconfig.json
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webgpu/tests/cts/checkout/tsconfig.json')
-rw-r--r--dom/webgpu/tests/cts/checkout/tsconfig.json64
1 files changed, 64 insertions, 0 deletions
diff --git a/dom/webgpu/tests/cts/checkout/tsconfig.json b/dom/webgpu/tests/cts/checkout/tsconfig.json
new file mode 100644
index 0000000000..6d3b0d98bf
--- /dev/null
+++ b/dom/webgpu/tests/cts/checkout/tsconfig.json
@@ -0,0 +1,64 @@
+{
+ "extends": "./node_modules/gts/tsconfig-google.json",
+ "compilerOptions": {
+ "lib": ["dom", "es2020"],
+ "module": "esnext",
+ /* Output options */
+ "noEmit": true,
+ /* Strict type-checking options */
+ "allowJs": true,
+ "checkJs": false,
+ "strict": true,
+ /* tsc lint options */
+ "allowUnusedLabels": false,
+ "noImplicitOverride": true,
+ "noImplicitReturns": true,
+ /* These should be caught by eslint instead */
+ "noFallthroughCasesInSwitch": false,
+ "noUnusedLocals": false,
+ "noUnusedParameters": false,
+ "allowUnreachableCode": true,
+ /* Compiler warnings we intentionally don't use */
+ // - Would be nice, but produces lots of errors that probably aren't worth fixing
+ "noUncheckedIndexedAccess": false,
+ // - We could make our code pass this, but it doesn't seem to provide much value to us
+ "noPropertyAccessFromIndexSignature": false,
+ // - Doesn't work with @webgpu/types right now, also has annoying interactions and limited value
+ "exactOptionalPropertyTypes": false,
+ /* Module Options */
+ "moduleResolution": "node",
+ "esModuleInterop": false,
+ "isolatedModules": true,
+ "skipLibCheck": true,
+ "target": "es2020"
+ // @tsconfig/strictest is a useful reference for new options:
+ // https://github.com/tsconfig/bases/blob/main/bases/strictest.json
+ },
+ "include": [
+ "src/**/*.ts",
+ "src/external/**/*.js",
+ ],
+ "typedocOptions": {
+ "entryPointStrategy": "expand",
+ "entryPoints": [
+ "src/common/framework/",
+ "src/common/util/",
+ "src/webgpu/",
+ ],
+ "exclude": [
+ "**/*.spec.ts",
+ "**/*.html.ts",
+ "src/*/listing.ts",
+ "src/webgpu/util/device_pool.ts",
+ ],
+ "excludeInternal": true,
+ "excludeProtected": true,
+ "excludePrivate": true,
+ "validation": {
+ "invalidLink": true,
+ "notExported": false,
+ },
+ "readme": "./docs/helper_index.txt",
+ "out": "docs/tsdoc/"
+ }
+}