summaryrefslogtreecommitdiffstats
path: root/gfx/cairo/libpixman/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gfx/cairo/libpixman/src/meson.build')
-rw-r--r--gfx/cairo/libpixman/src/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/gfx/cairo/libpixman/src/meson.build b/gfx/cairo/libpixman/src/meson.build
index 652cda3418..62ec66bec3 100644
--- a/gfx/cairo/libpixman/src/meson.build
+++ b/gfx/cairo/libpixman/src/meson.build
@@ -20,7 +20,7 @@
config_h = configure_file(
configuration : config,
- output : 'config.h'
+ output : 'pixman-config.h'
)
version_h = configure_file(
@@ -31,7 +31,8 @@ version_h = configure_file(
)
libpixman_extra_cargs = []
-if cc.has_function_attribute('dllexport')
+default_library = get_option('default_library')
+if default_library != 'static' and cc.has_function_attribute('dllexport')
libpixman_extra_cargs = ['-DPIXMAN_API=__declspec(dllexport)']
endif