summaryrefslogtreecommitdiffstats
path: root/ipc/ipdl/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'ipc/ipdl/Makefile.in')
-rw-r--r--ipc/ipdl/Makefile.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/ipc/ipdl/Makefile.in b/ipc/ipdl/Makefile.in
index 7a4d2acfba..6ebff9cba0 100644
--- a/ipc/ipdl/Makefile.in
+++ b/ipc/ipdl/Makefile.in
@@ -18,14 +18,14 @@ ipdl_py_deps := \
# NB: the IPDL compiler manages .ipdl-->.h/.cpp dependencies itself,
# which is why we don't have explicit .h/.cpp targets here
-ipdl.track: $(ALL_IPDLSRCS) $(srcdir)/sync-messages.ini $(srcdir)/message-metadata.ini $(ipdl_py_deps)
+ipdl.track: $(ALL_IPDLSRCS) $(ALL_IPDLSRCS_FILE) $(srcdir)/sync-messages.ini $(srcdir)/message-metadata.ini $(ipdl_py_deps)
$(PYTHON3) $(srcdir)/ipdl.py \
--sync-msg-list=$(srcdir)/sync-messages.ini \
--msg-metadata=$(srcdir)/message-metadata.ini \
--outheaders-dir=_ipdlheaders \
--outcpp-dir=. \
$(IPDLDIRS:%=-I%) \
- $(ALL_IPDLSRCS)
+ --file-list $(ALL_IPDLSRCS_FILE)
touch $@
export:: ipdl.track