summaryrefslogtreecommitdiffstats
path: root/ipc/ipdl/test/cxx/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'ipc/ipdl/test/cxx/Makefile.in')
-rw-r--r--ipc/ipdl/test/cxx/Makefile.in45
1 files changed, 0 insertions, 45 deletions
diff --git a/ipc/ipdl/test/cxx/Makefile.in b/ipc/ipdl/test/cxx/Makefile.in
deleted file mode 100644
index b32533a648..0000000000
--- a/ipc/ipdl/test/cxx/Makefile.in
+++ /dev/null
@@ -1,45 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-IPDLTESTSRCS = $(filter Test%,$(CPPSRCS))
-IPDLTESTS = $(IPDLTESTSRCS:.cpp=)
-
-EXTRA_PROTOCOLS = \
- TestEndpointBridgeSub \
- $(NULL)
-
-IPDLTESTHDRS = $(addprefix $(srcdir)/,$(addsuffix .h,$(IPDLTESTS)))
-
-TESTER_TEMPLATE := $(srcdir)/IPDLUnitTests.template.cpp
-GENTESTER := $(srcdir)/genIPDLUnitTests.py
-
-include $(topsrcdir)/config/rules.mk
-
-
-IPDLUNITTEST_BIN = $(DEPTH)/dist/bin/ipdlunittest$(BIN_SUFFIX)
-
-IPDLUnitTests.cpp : Makefile.in moz.build $(GENTESTER) $(TESTER_TEMPLATE) $(IPDLTESTHDRS)
- $(PYTHON3) $(GENTESTER) $(TESTER_TEMPLATE) -t $(IPDLTESTS) -e $(EXTRA_PROTOCOLS) > $@
-
-check-proc::
- @$(EXIT_ON_ERROR) \
- for test in $(IPDLTESTS); do \
- $(RUN_TEST_PROGRAM) $(IPDLUNITTEST_BIN) $$test ; \
- done
-
-check-thread::
- @$(EXIT_ON_ERROR) \
- for test in $(IPDLTESTS); do \
- $(RUN_TEST_PROGRAM) $(IPDLUNITTEST_BIN) thread:$$test ; \
- done
-
-check:: check-proc check-thread
-
-check-valgrind::
- @$(EXIT_ON_ERROR) \
- for test in $(IPDLTESTS); do \
- $(RUN_TEST_PROGRAM) -g -d \
- valgrind -a '--leak-check=full --trace-children=yes -q' \
- $(IPDLUNITTEST_BIN) $$test ; \
- done