summaryrefslogtreecommitdiffstats
path: root/js/src/rust/shared/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'js/src/rust/shared/Cargo.toml')
-rw-r--r--js/src/rust/shared/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/js/src/rust/shared/Cargo.toml b/js/src/rust/shared/Cargo.toml
new file mode 100644
index 0000000000..e3218354be
--- /dev/null
+++ b/js/src/rust/shared/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+name = "jsrust_shared"
+version = "0.1.0"
+authors = ["The Spidermonkey developers"]
+license = "MPL-2.0"
+
+[lib]
+crate-type = ["rlib"]
+name = "jsrust_shared"
+path = "lib.rs"
+
+[dependencies]
+encoding_c = "0.9.5"
+encoding_c_mem = "0.2.4"
+smoosh = { path = "../../frontend/smoosh", optional = true }
+mozglue-static = { path = "../../../../mozglue/static/rust" }
+gluesmith = { path = "../../fuzz-tests/gluesmith", optional = true }
+icu_capi = { version = "1.4.0", optional = true, default-features= false, features = ["any_provider", "compiled_data", "icu_segmenter"] }
+unicode-bidi-ffi = { path = "../../../../intl/bidi/rust/unicode-bidi-ffi" }
+
+[features]
+simd-accel = ['encoding_c/simd-accel']
+icu4x = ['icu_capi']
+
+# Uncomment this to enable perf support in release mode.
+#[profile.release]
+#debug = true
+
+[package.metadata.cargo-udeps.ignore]
+normal = ["mozilla-central-workspace-hack"]