summaryrefslogtreecommitdiffstats
path: root/layout/reftests/bugs/712849-1.html
diff options
context:
space:
mode:
Diffstat (limited to 'layout/reftests/bugs/712849-1.html')
-rw-r--r--layout/reftests/bugs/712849-1.html39
1 files changed, 39 insertions, 0 deletions
diff --git a/layout/reftests/bugs/712849-1.html b/layout/reftests/bugs/712849-1.html
new file mode 100644
index 0000000000..83b4c43405
--- /dev/null
+++ b/layout/reftests/bugs/712849-1.html
@@ -0,0 +1,39 @@
+<!DOCTYPE html>
+<html><head>
+<meta http-equiv="content-type" content="text/html; charset=UTF-8">
+ <title>testcase</title>
+<style>
+.tt {
+ border-collapse: collapse;
+}
+.nix {
+ display: none;
+}
+.ref {
+ border: solid 3px darkred;
+}
+
+td {
+ width: 20px;
+ height: 20px;
+}
+
+</style>
+<script>
+
+function test ()
+{
+ document.getElementById ("2").className = "nix";
+ document.getElementById ("3").className = "ref";
+}
+</script>
+</head>
+<body onload="test()">
+ <table class="tt">
+ <tr id="1"><td >&nbsp;</td></tr>
+ <tr id="2"><td >&nbsp;</td></tr>
+ <tr id="3"><td >&nbsp;</td></tr>
+ <tr><td>&nbsp;</td></tr>
+ </table>
+</body>
+</html>