summaryrefslogtreecommitdiffstats
path: root/layout/reftests/text-stroke/webkit-text-stroke-property-005.html
diff options
context:
space:
mode:
Diffstat (limited to 'layout/reftests/text-stroke/webkit-text-stroke-property-005.html')
-rw-r--r--layout/reftests/text-stroke/webkit-text-stroke-property-005.html26
1 files changed, 26 insertions, 0 deletions
diff --git a/layout/reftests/text-stroke/webkit-text-stroke-property-005.html b/layout/reftests/text-stroke/webkit-text-stroke-property-005.html
new file mode 100644
index 0000000000..306abb6789
--- /dev/null
+++ b/layout/reftests/text-stroke/webkit-text-stroke-property-005.html
@@ -0,0 +1,26 @@
+<!DOCTYPE html>
+<html>
+<meta charset="utf-8">
+<title>webkit-text-stroke: 2px green</title>
+<link rel="author" title="Jeremy Chen" href="jeremychen@mozilla.com">
+<link rel="author" title="Mozilla" href="https://www.mozilla.org">
+<link rel="help" href="https://compat.spec.whatwg.org/#the-webkit-text-stroke">
+<meta name="assert" content="webkit-text-stroke-color should take effect">
+<link rel="match" href="webkit-text-stroke-property-005-ref.html">
+<style>
+text {
+ padding-left: 0px;
+ color: red;
+ font-size: 64px;
+ -webkit-text-fill-color: transparent;
+ -webkit-text-stroke: 2px green;
+}
+</style>
+<body>
+<div style="width: 500px; height: 200px;">
+<text>TEXT stroke</text>
+<!-- need this inline-block to make sure text is rendered at the same position as the SVG reference -->
+<div style="display:inline-block; width:0px; height:100px;"/>
+</div>
+<body>
+<html>