summaryrefslogtreecommitdiffstats
path: root/modules/libpref/init/StaticPrefList.yaml
diff options
context:
space:
mode:
Diffstat (limited to 'modules/libpref/init/StaticPrefList.yaml')
-rw-r--r--modules/libpref/init/StaticPrefList.yaml365
1 files changed, 268 insertions, 97 deletions
diff --git a/modules/libpref/init/StaticPrefList.yaml b/modules/libpref/init/StaticPrefList.yaml
index 835450712a..f32e8a9e8f 100644
--- a/modules/libpref/init/StaticPrefList.yaml
+++ b/modules/libpref/init/StaticPrefList.yaml
@@ -478,11 +478,6 @@
value: true
mirror: always
-- name: apz.drag.initial.enabled
- type: RelaxedAtomicBool
- value: true
- mirror: always
-
- name: apz.drag.touch.enabled
type: RelaxedAtomicBool
value: true
@@ -591,12 +586,6 @@
value: 1.0f
mirror: always
-# new scrollbar code for desktop zooming
-- name: apz.force_disable_desktop_zooming_scrollbars
- type: RelaxedAtomicBool
- value: false
- mirror: always
-
#ifdef MOZ_WIDGET_GTK
- name: apz.gtk.kinetic_scroll.enabled
type: RelaxedAtomicBool
@@ -680,11 +669,6 @@
value: false
mirror: always
-- name: apz.mvm.force-enabled
- type: RelaxedAtomicBool
- value: true
- mirror: always
-
- name: apz.one_touch_pinch.enabled
type: RelaxedAtomicBool
value: @IS_ANDROID@
@@ -2255,17 +2239,6 @@
value: 20
mirror: always
-# Whether window.location.reload() and window.history.go(0) should be blocked
-# when called directly from a window resize event handler.
-#
-# This used to be necessary long ago to prevent terrible UX when using stuff
-# like TypeAheadFind (bug 258917), but it also causes compat issues on mobile
-# (bug 1570566).
-- name: dom.block_reload_from_resize_event_handler
- type: bool
- value: false
- mirror: always
-
# Enable CacheAPI in private browsing mode with encryption
- name: dom.cache.privateBrowsing.enabled
type: RelaxedAtomicBool
@@ -2405,7 +2378,7 @@
# Whether CustomStateSet is enabled
- name: dom.element.customstateset.enabled
type: RelaxedAtomicBool
- value: false
+ value: true
mirror: always
rust: true
@@ -2637,12 +2610,24 @@
value: true
mirror: always
+# Expose Window.TextEvent and make the builtin editors dispatch `textInput`
+# event as a default action of `beforeinput`.
+- name: dom.events.textevent.enabled
+ type: bool
+ value: false
+ mirror: always
+
# Whether to expose test interfaces of various sorts
- name: dom.expose_test_interfaces
type: bool
value: false
mirror: always
+- name: dom.fetchKeepalive.enabled
+ type: RelaxedAtomicBool
+ value: false
+ mirror: always
+
- name: dom.fetchObserver.enabled
type: RelaxedAtomicBool
value: false
@@ -2801,7 +2786,11 @@
value: false
mirror: always
-# Whether innerWidth / innerHeight return rounded or fractional sizes.
+# How innerWidth / innerHeight return rounded or fractional sizes.
+#
+# 0 or others: Do not round at all.
+# 1: Round.
+# 2: Truncate.
#
# NOTE(emilio): Fractional sizes are not web-compatible, see the regressions
# from bug 1676843, but we want to expose the fractional sizes (probably in
@@ -2809,9 +2798,9 @@
# time being.
#
# [1]: https://github.com/w3c/csswg-drafts/issues/5260
-- name: dom.innerSize.rounded
- type: bool
- value: true
+- name: dom.innerSize.rounding
+ type: uint32_t
+ value: 2
mirror: always
# Whether we conform to Input Events Level 1 or Input Events Level 2.
@@ -2856,13 +2845,6 @@
value: 8
mirror: always
-# Enable not moving the cursor to end when a text input or textarea has .value
-# set to the value it already has. By default, enabled.
-- name: dom.input.skip_cursor_move_for_same_value_set
- type: bool
- value: true
- mirror: always
-
# How often to check for CPOW timeouts (ms). CPOWs are only timed
# out by the hang monitor.
- name: dom.ipc.cpow.timeout
@@ -3520,7 +3502,7 @@
# Enable Screen Wake Lock API
- name: dom.screenwakelock.enabled
type: bool
- value: @IS_EARLY_BETA_OR_EARLIER@
+ value: true
mirror: always
# Whether to enable the JavaScript start-up cache. This causes one of the first
@@ -3848,10 +3830,10 @@
value: 120000
mirror: always
-# SetDocumentURI security option, enforces origin check
+# Enforce origin check whenever a content process tries to set a document URI
- name: dom.security.setdocumenturi
type: bool
- value: @IS_EARLY_BETA_OR_EARLIER@
+ value: true
mirror: always
# Whether or not selection events on text controls are enabled.
@@ -4153,6 +4135,12 @@
value: false
mirror: always
+- name: dom.text_fragments.enabled
+ type: RelaxedAtomicBool
+ value: false
+ mirror: always
+ rust: true
+
- name: dom.textMetrics.actualBoundingBox.enabled
type: RelaxedAtomicBool
value: true
@@ -4583,6 +4571,14 @@
value: @IS_NOT_ANDROID@
mirror: always
+# Whether allowing selection across the boundary
+# between shadow DOM and light DOM.
+# This is based on https://github.com/mfreed7/shadow-dom-selection
+- name: dom.shadowdom.selection_across_boundary.enabled
+ type: bool
+ value: @IS_NIGHTLY_BUILD@
+ mirror: always
+
# NOTE: This preference is used in unit tests. If it is removed or its default
# value changes, please update test_sharedMap_static_prefs.js accordingly.
- name: dom.webcomponents.shadowdom.report_usage
@@ -4632,11 +4628,14 @@
mirror: always
rust: true
-- name: dom.webgpu.swap-chain.external-texture-dx12
+- name: dom.webgpu.allow-present-without-readback
type: RelaxedAtomicBool
+#if defined(XP_WIN)
+ value: true
+#else
value: false
+#endif
mirror: always
- rust: true
# For testing purposes, crash if we don't get a hardware adapter.
- name: dom.webgpu.testing.assert-hardware-adapter
@@ -4715,6 +4714,13 @@
#endif
mirror: always
+# Setting log level for notification modules.
+# The value follows the enum ConsoleLogLevel in ConsoleInstance.webidl.
+- name: dom.webnotifications.loglevel
+ type: String
+ value: Error
+ mirror: never
+
# Is support for Window.event enabled?
- name: dom.window.event.enabled
type: bool
@@ -4850,7 +4856,7 @@
# Whether allowing using <tab> to move focus to root elements
- name: dom.disable_tab_focus_to_root_element
type: bool
- value: @IS_NIGHTLY_BUILD@
+ value: true
mirror: always
#---------------------------------------------------------------------------
@@ -5083,14 +5089,6 @@
value: @IS_NOT_ANDROID@
mirror: never
-# This pref has no effect within fission windows, it only controls the
-# behaviour within non-fission windows. If true, preserve browsing contexts
-# between process swaps.
-- name: fission.preserve_browsing_contexts
- type: bool
- value: true
- mirror: always
-
# Disable storing the session history in the parent process, and accessing it
# over IPC from the child processes.
- name: fission.disableSessionHistoryInParent
@@ -5132,15 +5130,6 @@
value: false
mirror: always
-# If true, allow process-switching documents loaded by <object> and <embed>
-# elements into a remote process.
-# NOTE: This pref has no impact outside of windows with the
-# `useRemoteSubframes` flag set.
-- name: fission.remoteObjectEmbed
- type: bool
- value: true
- mirror: always
-
# The strategy used to control how sites are isolated into separate processes
# when Fisison is enabled. This pref has no effect if Fission is disabled.
# See the `WebContentIsolationStrategy` enum in `ProcessIsolation.cpp`.
@@ -5829,6 +5818,11 @@
value: 10000
mirror: always
+- name: gfx.canvas.remote.use-draw-image-fast-path
+ type: RelaxedAtomicBool
+ value: true
+ mirror: always
+
- name: gfx.canvas.willreadfrequently.enabled
type: bool
#if defined(XP_WIN)
@@ -6056,6 +6050,13 @@
value: 0
mirror: always
+# Whether to disable downloadable font cache so that behavior is consistently
+# the uncached load behavior across pages (useful for testing reflow problems)
+- name: gfx.downloadable_fonts.disable_cache
+ type: RelaxedAtomicBool
+ value: false
+ mirror: always
+
# Whether to preserve color bitmap tables in fonts (bypassing OTS).
# Currently these are supported only on platforms where we use Freetype
# to render fonts (Linux/Gtk and Android).
@@ -6811,7 +6812,7 @@
# for devices with weak GPUs, or when running SWGL.
- name: gfx.webrender.low-quality-pinch-zoom
type: bool
-#if defined(MOZ_WIDGET_ANDROID)
+#if defined(MOZ_WIDGET_ANDROID) && defined(NIGHTLY_BUILD)
value: true
#else
value: false
@@ -6831,13 +6832,21 @@
# Enable VideoProcessor Super Resolution for video overlay
- name: gfx.webrender.overlay-vp-super-resolution
type: bool
+#if defined(XP_WIN)
+ value: true
+#else
value: false
+#endif
mirror: once
# Enable VideoProcessor-HDR on SDR content for video overlay
- name: gfx.webrender.overlay-vp-auto-hdr
type: bool
+#if defined(XP_WIN)
+ value: true
+#else
value: false
+#endif
mirror: once
# Use vsync events generated by hardware
@@ -6851,6 +6860,11 @@
value: false
mirror: always
+- name: gfx.remote-texture.recycle.disabled
+ type: RelaxedAtomicBool
+ value: false
+ mirror: always
+
#---------------------------------------------------------------------------
# Prefs starting with "gl." (OpenGL)
#---------------------------------------------------------------------------
@@ -7622,6 +7636,13 @@
value: false
mirror: always
set_spidermonkey_pref: startup
+
+ # Experimental support for Uint8Array base64/hex in JavaScript.
+- name: javascript.options.experimental.uint8array_base64
+ type: bool
+ value: false
+ mirror: always
+ set_spidermonkey_pref: startup
#endif // NIGHTLY_BUILD
# Experimental support for ArrayBuffer.prototype.transfer{,ToFixedLength}() in JavaScript.
@@ -7646,6 +7667,14 @@
mirror: always
#endif // NIGHTLY_BUILD
+#ifdef ENABLE_JSON_PARSE_WITH_SOURCE
+- name: javascript.options.experimental.json_parse_with_source
+ type: bool
+ value: false
+ mirror: always
+ set_spidermonkey_pref: startup
+#endif // ENABLE_JSON_PARSE_WITH_SOURCE
+
- name: javascript.options.wasm_caching
type: bool
value: true
@@ -7932,6 +7961,16 @@
value: false
mirror: always
+# Whether to disable the jit within the main process
+- name: javascript.options.main_process_disable_jit
+ type: bool
+#ifdef XP_IOS
+ value: true
+#else
+ value: false
+#endif
+ mirror: always
+
#---------------------------------------------------------------------------
# Prefs starting with "layers."
#---------------------------------------------------------------------------
@@ -8339,6 +8378,13 @@
mirror: always
rust: true
+# Whether @starting-style is enabled?
+- name: layout.css.starting-style-at-rules.enabled
+ type: RelaxedAtomicBool
+ value: false
+ mirror: always
+ rust: true
+
# Should we look for counter ancestor scopes first?
- name: layout.css.counter-ancestor-scope.enabled
type: bool
@@ -8477,6 +8523,13 @@
mirror: always
rust: true
+# Is support for shape() enabled?
+- name: layout.css.basic-shape-shape.enabled
+ type: RelaxedAtomicBool
+ value: @IS_NIGHTLY_BUILD@
+ mirror: always
+ rust: true
+
# Is support for xywh() enabled?
- name: layout.css.basic-shape-xywh.enabled
type: RelaxedAtomicBool
@@ -8637,35 +8690,14 @@
value: false
mirror: always
-# Is support for motion-path <basic-shape> other than path() enabled?
-# https://drafts.fxtf.org/motion-1/#valdef-offset-path-basic-shape
-- name: layout.css.motion-path-basic-shapes.enabled
- type: RelaxedAtomicBool
- value: true
- mirror: always
- rust: true
-
-# Is support for motion-path <coord-box> enabled?
-# https://drafts.fxtf.org/motion-1/#valdef-offset-path-coord-box
-- name: layout.css.motion-path-coord-box.enabled
- type: RelaxedAtomicBool
- value: true
- mirror: always
- rust: true
-
-# Is support for motion-path ray() enabled?
-- name: layout.css.motion-path-ray.enabled
- type: RelaxedAtomicBool
- value: true
- mirror: always
- rust: true
-
-# Is support for motion-path offset-position enabled?
-- name: layout.css.motion-path-offset-position.enabled
- type: RelaxedAtomicBool
- value: true
+# Which model to use for CSS letter-spacing:
+# 0 - Gecko legacy model, spacing added to trailing side of letter
+# 1 - WebKit/Blink-compatible, spacing always added to right-hand side
+# 2 - Symmetrical spacing, half added to each side
+- name: layout.css.letter-spacing.model
+ type: int32_t
+ value: 0
mirror: always
- rust: true
# Is support for motion-path url enabled?
- name: layout.css.motion-path-url.enabled
@@ -8740,6 +8772,13 @@
mirror: always
rust: true
+# Whether @scope rule is enabled
+- name: layout.css.at-scope.enabled
+ type: RelaxedAtomicBool
+ value: false
+ mirror: always
+ rust: true
+
# Dictates whether or not the prefers contrast media query will be
# usable.
# true: prefers-contrast will toggle based on OS and browser settings.
@@ -8815,15 +8854,22 @@
# Is support for -moz-prefixed transform properties enabled?
- name: layout.css.prefixes.transforms
type: bool
- value: @IS_NOT_NIGHTLY_BUILD@
+ value: false
mirror: always
# Is support for -moz-prefixed transition properties enabled?
- name: layout.css.prefixes.transitions
type: bool
- value: @IS_NOT_NIGHTLY_BUILD@
+ value: false
mirror: always
+# Enable relative color syntax: https://drafts.csswg.org/css-color-5/#relative-colors
+- name: layout.css.relative-color-syntax.enabled
+ type: RelaxedAtomicBool
+ value: false
+ mirror: always
+ rust: true
+
# Is CSS error reporting enabled?
- name: layout.css.report_errors
type: bool
@@ -8850,7 +8896,7 @@
mirror: always
# Whether the scroll-driven animations generated by CSS is enabled. This
-# also include animation-timelime property.
+# also include animation-timeline property.
- name: layout.css.scroll-driven-animations.enabled
type: RelaxedAtomicBool
value: false
@@ -8981,7 +9027,7 @@
# Support for the css Zoom property.
- name: layout.css.zoom.enabled
type: RelaxedAtomicBool
- value: @IS_NIGHTLY_BUILD@
+ value: true
mirror: always
rust: true
@@ -9357,6 +9403,16 @@
mirror: always
rust: true
+# Is matching video-dynamic-range: high allowed?
+- name: layout.css.video-dynamic-range.allows-high
+ type: RelaxedAtomicBool
+#if defined(XP_MACOSX) || defined(NIGHTLY_BUILD)
+ value: true
+#else
+ value: false
+#endif
+ mirror: always
+
# Whether frame visibility tracking is enabled globally.
- name: layout.framevisibility.enabled
type: bool
@@ -9509,6 +9565,20 @@
mirror: always
rust: true
+# Whether to disable forced centering of binary operators (+, =, ...).
+- name: mathml.centered_operators.disabled
+ type: bool
+ value: true
+ mirror: always
+ rust: true
+
+# Whether to disable extra top/bottom spacing for stretchy operators.
+- name: mathml.top_bottom_spacing_for_stretchy_operators.disabled
+ type: bool
+ value: true
+ mirror: always
+ rust: true
+
#---------------------------------------------------------------------------
# Prefs starting with "media."
#---------------------------------------------------------------------------
@@ -9553,6 +9623,20 @@
value: 32768 # Measured in KiB
mirror: always
+# Multiplier to change the sample rate at which input-only streams run, so as
+# to similate clock drift.
+- name: media.cubeb.input_drift_factor
+ type: AtomicFloat
+ mirror: always
+ value: 1.f
+
+# Multiplier to change the sample rate at which output-only streams run, so as
+# to similate clock drift.
+- name: media.cubeb.output_drift_factor
+ type: AtomicFloat
+ mirror: always
+ value: 1.f
+
# Whether cubeb is sandboxed (AudioIPC)
- name: media.cubeb.sandbox
type: bool
@@ -11172,6 +11256,19 @@
mirror: always
#endif
+# Bug 1860492 - Deprecate and remove theora
+- name: media.theora.enabled
+ type: RelaxedAtomicBool
+ value: @IS_NOT_NIGHTLY_BUILD@
+ mirror: always
+
+# When this is true, the protection mask that Firefox replies to Widevine API
+# QueryOutputProtectionStatus is `kProtectionHDCP` when no potential capturing.
+- name: media.widevine.hdcp-protection-mask
+ type: RelaxedAtomicBool
+ value: true
+ mirror: always
+
#---------------------------------------------------------------------------
# Prefs starting with "memory."
#---------------------------------------------------------------------------
@@ -11569,6 +11666,13 @@
value: true
mirror: always
+# If true, when browser code itself makes network requests, default to
+# omitting credentials.
+- name: network.fetch.systemDefaultsToOmittingCredentials
+ type: RelaxedAtomicBool
+ value: true
+ mirror: always
+
# Whether to strip auth headers for redirected http channels
# https://fetch.spec.whatwg.org/#http-redirect-fetch
- name: network.http.redirect.stripAuthHeader
@@ -11584,6 +11688,12 @@
mirror: always
do_not_use_directly: true
+# Whether to add urgency and incremental to request headers
+- name: network.http.priority_header.enabled
+ type: bool
+ value: true
+ mirror: always
+
# The maximum allowed length for a referrer header - 4096 default.
# 0 means no limit.
- name: network.http.referer.referrerLengthLimit
@@ -11882,7 +11992,7 @@
# (e.g. `<script>`) is enabled.
- name: network.fetchpriority.enabled
type: RelaxedAtomicBool
- value: false
+ value: @IS_NIGHTLY_BUILD@
mirror: always
# Adjustments to apply to the internal priority of <link rel=preload as=script
@@ -12734,6 +12844,19 @@
value: false
mirror: always
+# Allows use of a protocol exception list that will bypass defaultURI parser
+- name: network.url.some_schemes_bypass_defaultURI_fallback
+ type: RelaxedAtomicBool
+ value: true
+ mirror: always
+
+# A list of schemes to allow for bypassing defaultURI as default
+# This is only used when network.url.some_schemes_bypass_defaultURI_fallback is true
+- name: network.url.simple_uri_schemes
+ type: String
+ value: ""
+ mirror: never
+
# The maximum allowed length for a URL - 32MB default.
# If 0 that means no limit.
- name: network.url.max-length
@@ -12804,6 +12927,16 @@
value: true
mirror: always
+# When true, origin A and origin B will be coalesced if they have an overlap
+# in IP addresses as advertized by DNS, regardless if the existing connection
+# to origin A is not to an IP present in B's DNS response.
+# When false, an existing connection will only be reused if the
+# connection's remote IP is also present in B's DNS response.
+- name: network.http.http2.aggressive_coalescing
+ type: RelaxedAtomicBool
+ value: false
+ mirror: always
+
- name: network.http.http2.ping-threshold
type: RelaxedAtomicInt32
value: 58
@@ -13052,6 +13185,12 @@
value: false
mirror: always
+# Whether to prefer IPv6 name lookups.
+- name: network.dns.preferIPv6
+ type: RelaxedAtomicBool
+ value: false
+ mirror: always
+
# Whether to add additional record IPs to the cache
- name: network.trr.add_additional_records
type: RelaxedAtomicBool
@@ -13186,6 +13325,12 @@
value: true
mirror: always
+ # The length of cnonce string used in HTTP digest auth.
+- name: network.http.digest_auth_cnonce_length
+ type: uint32_t
+ value: 16
+ mirror: always
+
# If true, HTTP response content-type headers will be parsed using the standards-compliant MimeType parser
- name: network.standard_content_type_parsing.response_headers
type: RelaxedAtomicBool
@@ -13259,6 +13404,17 @@
value: "file,moz-gio"
mirror: never
+# Enable off-main-thread decompression of network streams
+- name: network.decompression_off_mainthread
+ type: bool
+ value: true
+ mirror: always
+
+# Minimum content-lengthe to use off-main-thread decompression of network streams
+- name: network.decompression_off_mainthread_min_size
+ type: int32_t
+ value: 512
+ mirror: always
#---------------------------------------------------------------------------
# Prefs starting with "nglayout."
@@ -13477,6 +13633,16 @@
value: true
mirror: always
+# Determines if and when to center pages on a sheet horiontally when printing.
+# With a setting of 2, it's guaranteed that A4 on US Letter will be centered.
+# 0: never,
+# 1: always,
+# 2: when the ratio of sheet to page size after content scaling is near 1.0
+- name: print.center_page_on_sheet
+ type: RelaxedAtomicUint32
+ value: 2
+ mirror: always
+
#---------------------------------------------------------------------------
# Prefs starting with "privacy."
#---------------------------------------------------------------------------
@@ -13779,7 +13945,7 @@
# Enable the heuristic to allow storage access for windows opened using window.open()
- name: privacy.restrict3rdpartystorage.heuristic.redirect
type: bool
- value: true
+ value: @IS_NOT_NIGHTLY_BUILD@
mirror: always
# Anti-tracking permission expiration.
@@ -15948,6 +16114,11 @@
type: RelaxedAtomicBool
value: true
mirror: always
+
+- name: widget.macos.titlebar-blend-mode.behind-window
+ type: RelaxedAtomicBool
+ value: false
+ mirror: always
#endif
# Whether native GTK global menubar support is enabled.