summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/test/src/evaluation.spec.ts
diff options
context:
space:
mode:
Diffstat (limited to 'remote/test/puppeteer/test/src/evaluation.spec.ts')
-rw-r--r--remote/test/puppeteer/test/src/evaluation.spec.ts7
1 files changed, 4 insertions, 3 deletions
diff --git a/remote/test/puppeteer/test/src/evaluation.spec.ts b/remote/test/puppeteer/test/src/evaluation.spec.ts
index 3305b59cc2..88cccb82dd 100644
--- a/remote/test/puppeteer/test/src/evaluation.spec.ts
+++ b/remote/test/puppeteer/test/src/evaluation.spec.ts
@@ -408,9 +408,10 @@ describe('Evaluation specs', function () {
return (error = error_);
});
expect(error).toBeTruthy();
- expect(error.message).toContain(
- 'JSHandles can be evaluated only in the context they were created'
- );
+ expect(error.message).atLeastOneToContain([
+ 'JSHandles can be evaluated only in the context they were created',
+ "Trying to evaluate JSHandle from different frames. Usually this means you're using a handle from a page on a different page.",
+ ]);
});
it('should simulate a user gesture', async () => {
const {page} = await getTestState();