summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/test/src/injected.spec.ts
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--remote/test/puppeteer/test/src/injected.spec.ts49
1 files changed, 49 insertions, 0 deletions
diff --git a/remote/test/puppeteer/test/src/injected.spec.ts b/remote/test/puppeteer/test/src/injected.spec.ts
new file mode 100644
index 0000000000..5f3696d3f6
--- /dev/null
+++ b/remote/test/puppeteer/test/src/injected.spec.ts
@@ -0,0 +1,49 @@
+/**
+ * @license
+ * Copyright 2022 Google Inc.
+ * SPDX-License-Identifier: Apache-2.0
+ */
+
+import expect from 'expect';
+import {LazyArg} from 'puppeteer-core/internal/common/LazyArg.js';
+
+import {getTestState, setupTestBrowserHooks} from './mocha-utils.js';
+
+describe('PuppeteerUtil tests', function () {
+ setupTestBrowserHooks();
+
+ it('should work', async () => {
+ const {page} = await getTestState();
+
+ const world = page.mainFrame().isolatedRealm();
+ const value = await world.evaluate(
+ PuppeteerUtil => {
+ return typeof PuppeteerUtil === 'object';
+ },
+ LazyArg.create(context => {
+ return context.puppeteerUtil;
+ })
+ );
+ expect(value).toBeTruthy();
+ });
+
+ describe('createFunction tests', function () {
+ it('should work', async () => {
+ const {page} = await getTestState();
+
+ const world = page.mainFrame().isolatedRealm();
+ const value = await world.evaluate(
+ ({createFunction}, fnString) => {
+ return createFunction(fnString)(4);
+ },
+ LazyArg.create(context => {
+ return context.puppeteerUtil;
+ }),
+ (() => {
+ return 4;
+ }).toString()
+ );
+ expect(value).toBe(4);
+ });
+ });
+});