summaryrefslogtreecommitdiffstats
path: root/security/nss/cmd/pkix-errcodes
diff options
context:
space:
mode:
Diffstat (limited to 'security/nss/cmd/pkix-errcodes')
-rw-r--r--security/nss/cmd/pkix-errcodes/Makefile47
-rw-r--r--security/nss/cmd/pkix-errcodes/manifest.mn15
-rw-r--r--security/nss/cmd/pkix-errcodes/pkix-errcodes.c34
-rw-r--r--security/nss/cmd/pkix-errcodes/pkix-errcodes.gyp24
4 files changed, 120 insertions, 0 deletions
diff --git a/security/nss/cmd/pkix-errcodes/Makefile b/security/nss/cmd/pkix-errcodes/Makefile
new file mode 100644
index 0000000000..6e1d4ecdfc
--- /dev/null
+++ b/security/nss/cmd/pkix-errcodes/Makefile
@@ -0,0 +1,47 @@
+#! gmake
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+#######################################################################
+# (1) Include initial platform-independent assignments (MANDATORY). #
+#######################################################################
+
+include manifest.mn
+
+#######################################################################
+# (2) Include "global" configuration information. (OPTIONAL) #
+#######################################################################
+
+include $(CORE_DEPTH)/coreconf/config.mk
+
+#######################################################################
+# (3) Include "component" configuration information. (OPTIONAL) #
+#######################################################################
+
+#######################################################################
+# (4) Include "local" platform-dependent assignments (OPTIONAL). #
+#######################################################################
+
+include ../platlibs.mk
+
+#######################################################################
+# (5) Execute "global" rules. (OPTIONAL) #
+#######################################################################
+
+include $(CORE_DEPTH)/coreconf/rules.mk
+
+#######################################################################
+# (6) Execute "component" rules. (OPTIONAL) #
+#######################################################################
+
+
+
+#######################################################################
+# (7) Execute "local" rules. (OPTIONAL). #
+#######################################################################
+
+
+include ../platrules.mk
+
diff --git a/security/nss/cmd/pkix-errcodes/manifest.mn b/security/nss/cmd/pkix-errcodes/manifest.mn
new file mode 100644
index 0000000000..bef0636921
--- /dev/null
+++ b/security/nss/cmd/pkix-errcodes/manifest.mn
@@ -0,0 +1,15 @@
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+CORE_DEPTH = ../..
+
+MODULE = nss
+
+CSRCS = pkix-errcodes.c
+
+REQUIRES = seccmd
+
+PROGRAM = pkix-errcodes
+
diff --git a/security/nss/cmd/pkix-errcodes/pkix-errcodes.c b/security/nss/cmd/pkix-errcodes/pkix-errcodes.c
new file mode 100644
index 0000000000..51608e49e8
--- /dev/null
+++ b/security/nss/cmd/pkix-errcodes/pkix-errcodes.c
@@ -0,0 +1,34 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+/*
+ * dumpcert.c
+ *
+ * dump certificate sample application
+ *
+ */
+
+#include <stdio.h>
+
+#include "pkix.h"
+#include "pkixt.h"
+#include "pkix_error.h"
+
+#undef PKIX_ERRORENTRY
+#define PKIX_ERRORENTRY(name, desc, plerr) #name
+
+const char *const PKIX_ErrorNames[] = {
+#include "pkix_errorstrings.h"
+};
+
+#undef PKIX_ERRORENTRY
+
+int
+main(int argc, char **argv)
+{
+ int i = 0;
+ for (; i < PKIX_NUMERRORCODES; ++i) {
+ printf("code %d %s\n", i, PKIX_ErrorNames[i]);
+ }
+ return 0;
+}
diff --git a/security/nss/cmd/pkix-errcodes/pkix-errcodes.gyp b/security/nss/cmd/pkix-errcodes/pkix-errcodes.gyp
new file mode 100644
index 0000000000..e305c07f81
--- /dev/null
+++ b/security/nss/cmd/pkix-errcodes/pkix-errcodes.gyp
@@ -0,0 +1,24 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+{
+ 'includes': [
+ '../../coreconf/config.gypi',
+ '../../cmd/platlibs.gypi'
+ ],
+ 'targets': [
+ {
+ 'target_name': 'pkix-errcodes',
+ 'type': 'executable',
+ 'sources': [
+ 'pkix-errcodes.c'
+ ],
+ 'dependencies': [
+ '<(DEPTH)/exports.gyp:nss_exports'
+ ]
+ }
+ ],
+ 'variables': {
+ 'module': 'nss'
+ }
+} \ No newline at end of file