summaryrefslogtreecommitdiffstats
path: root/security/nss/lib/dbm/config/config.mk
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--security/nss/lib/dbm/config/config.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/security/nss/lib/dbm/config/config.mk b/security/nss/lib/dbm/config/config.mk
new file mode 100644
index 0000000000..34bf5315d1
--- /dev/null
+++ b/security/nss/lib/dbm/config/config.mk
@@ -0,0 +1,27 @@
+#! gmake
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+#
+# These macros are defined by mozilla's configure script.
+# We define them manually here.
+#
+
+DEFINES += -DSTDC_HEADERS -DHAVE_STRERROR
+
+#
+# Most platforms have snprintf, so it's simpler to list the exceptions.
+#
+HAVE_SNPRINTF = 1
+DEFINES += -DHAVE_SNPRINTF
+
+ifeq (,$(filter-out NCR ReliantUNIX SCO_SV SCOOS UNIXWARE,$(OS_TARGET)))
+DEFINES += -DHAVE_SYS_BYTEORDER_H
+endif
+
+#
+# None of the platforms that we are interested in need to
+# define HAVE_MEMORY_H.
+#