summaryrefslogtreecommitdiffstats
path: root/security/nss/lib/dbm/src/config.mk
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--security/nss/lib/dbm/src/config.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/security/nss/lib/dbm/src/config.mk b/security/nss/lib/dbm/src/config.mk
new file mode 100644
index 0000000000..7ce86f8c57
--- /dev/null
+++ b/security/nss/lib/dbm/src/config.mk
@@ -0,0 +1,27 @@
+#! gmake
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+DEFINES += -DMEMMOVE -D__DBINTERFACE_PRIVATE
+
+#
+# Currently, override TARGETS variable so that only static libraries
+# are specifed as dependencies within rules.mk.
+#
+
+ifdef SHARED_LIBRARY
+ ifeq (,$(filter-out WIN%,$(OS_TARGET)))
+ DLLBASE=/BASE:0x30000000
+ RES=$(OBJDIR)/dbm.res
+ RESNAME=../include/dbm.rc
+ endif
+ ifeq ($(DLL_SUFFIX),dll)
+ DEFINES += -D_DLL
+ endif
+endif
+
+ifeq ($(OS_TARGET),AIX)
+ OS_LIBS += -lc_r
+endif