summaryrefslogtreecommitdiffstats
path: root/testing/mochitest/mochitest-e10s-utils.js
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mochitest/mochitest-e10s-utils.js')
-rw-r--r--testing/mochitest/mochitest-e10s-utils.js17
1 files changed, 17 insertions, 0 deletions
diff --git a/testing/mochitest/mochitest-e10s-utils.js b/testing/mochitest/mochitest-e10s-utils.js
new file mode 100644
index 0000000000..716e473c0c
--- /dev/null
+++ b/testing/mochitest/mochitest-e10s-utils.js
@@ -0,0 +1,17 @@
+// Utilities for running tests in an e10s environment.
+
+function e10s_init() {
+ // Listen for an 'oop-browser-crashed' event and log it so people analysing
+ // test logs have a clue about what is going on.
+ window.addEventListener(
+ "oop-browser-crashed",
+ event => {
+ let uri = event.target.currentURI;
+ console.error(
+ "remote browser crashed while on",
+ uri ? uri.spec : "<unknown>"
+ );
+ },
+ true
+ );
+}