summaryrefslogtreecommitdiffstats
path: root/testing/mozbase/rust/mozdevice/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--testing/mozbase/rust/mozdevice/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/mozbase/rust/mozdevice/Cargo.toml b/testing/mozbase/rust/mozdevice/Cargo.toml
new file mode 100644
index 0000000000..b5ecd9ea19
--- /dev/null
+++ b/testing/mozbase/rust/mozdevice/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+edition = "2021"
+name = "mozdevice"
+version = "0.5.2"
+authors = ["Mozilla"]
+description = "Client library for the Android Debug Bridge (adb)"
+keywords = [
+ "adb",
+ "android",
+ "firefox",
+ "geckoview",
+ "mozilla",
+]
+license = "MPL-2.0"
+repository = "https://hg.mozilla.org/mozilla-central/file/tip/testing/mozbase/rust/mozdevice"
+
+[dependencies]
+log = { version = "0.4", features = ["std"] }
+once_cell = "1.4.0"
+regex = { version = "1", default-features = false, features = ["perf", "std"] }
+tempfile = "3"
+thiserror = "1.0.25"
+walkdir = "2"
+unix_path = "1.0"
+uuid = { version = "1.0", features = ["serde", "v4"] }