summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_addition.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_comparison.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_division.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_addition.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_matrix_multiplication.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_scalar_multiplication.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_subtraction.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_vector_multiplication.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_multiplication.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_remainder.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_subtraction.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/ai_arithmetic.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/ai_comparison.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/bitwise.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/bitwise_shift.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/bool_logical.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_addition.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_comparison.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_division.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_addition.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_matrix_multiplication.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_scalar_multiplication.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_subtraction.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_vector_multiplication.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_multiplication.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_remainder.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_subtraction.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_addition.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_comparison.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_division.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_addition.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_matrix_multiplication.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_scalar_multiplication.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_subtraction.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_vector_multiplication.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_multiplication.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_remainder.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_subtraction.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/i32_arithmetic.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/i32_comparison.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/u32_arithmetic.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/u32_comparison.worker.js6
42 files changed, 252 insertions, 0 deletions
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_addition.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_addition.worker.js
new file mode 100644
index 0000000000..3f25d7f105
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_addition.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/af_addition.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_comparison.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_comparison.worker.js
new file mode 100644
index 0000000000..7cf5dd3314
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_comparison.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/af_comparison.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_division.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_division.worker.js
new file mode 100644
index 0000000000..17a9993f95
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_division.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/af_division.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_addition.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_addition.worker.js
new file mode 100644
index 0000000000..2bc11305ae
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_addition.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/af_matrix_addition.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_matrix_multiplication.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_matrix_multiplication.worker.js
new file mode 100644
index 0000000000..c22a0382f9
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_matrix_multiplication.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/af_matrix_matrix_multiplication.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_scalar_multiplication.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_scalar_multiplication.worker.js
new file mode 100644
index 0000000000..b5b23f073c
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_scalar_multiplication.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/af_matrix_scalar_multiplication.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_subtraction.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_subtraction.worker.js
new file mode 100644
index 0000000000..926d93f629
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_subtraction.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/af_matrix_subtraction.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_vector_multiplication.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_vector_multiplication.worker.js
new file mode 100644
index 0000000000..8e2de76fda
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_matrix_vector_multiplication.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/af_matrix_vector_multiplication.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_multiplication.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_multiplication.worker.js
new file mode 100644
index 0000000000..2a313bcbe7
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_multiplication.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/af_multiplication.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_remainder.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_remainder.worker.js
new file mode 100644
index 0000000000..79ff0a10a7
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_remainder.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/af_remainder.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_subtraction.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_subtraction.worker.js
new file mode 100644
index 0000000000..59de223470
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/af_subtraction.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/af_subtraction.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/ai_arithmetic.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/ai_arithmetic.worker.js
new file mode 100644
index 0000000000..35c5bad2bb
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/ai_arithmetic.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/ai_arithmetic.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/ai_comparison.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/ai_comparison.worker.js
new file mode 100644
index 0000000000..bf119f5a82
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/ai_comparison.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/ai_comparison.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/bitwise.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/bitwise.worker.js
new file mode 100644
index 0000000000..1b78a11416
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/bitwise.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/bitwise.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/bitwise_shift.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/bitwise_shift.worker.js
new file mode 100644
index 0000000000..50df7799cc
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/bitwise_shift.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/bitwise_shift.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/bool_logical.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/bool_logical.worker.js
new file mode 100644
index 0000000000..c97a65500a
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/bool_logical.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/bool_logical.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_addition.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_addition.worker.js
new file mode 100644
index 0000000000..b4d1ba4e9a
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_addition.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f16_addition.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_comparison.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_comparison.worker.js
new file mode 100644
index 0000000000..343e81cd66
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_comparison.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f16_comparison.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_division.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_division.worker.js
new file mode 100644
index 0000000000..df89b1d70f
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_division.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f16_division.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_addition.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_addition.worker.js
new file mode 100644
index 0000000000..3d37d6b028
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_addition.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f16_matrix_addition.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_matrix_multiplication.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_matrix_multiplication.worker.js
new file mode 100644
index 0000000000..f66a6197dc
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_matrix_multiplication.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f16_matrix_matrix_multiplication.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_scalar_multiplication.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_scalar_multiplication.worker.js
new file mode 100644
index 0000000000..560e1f8d73
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_scalar_multiplication.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f16_matrix_scalar_multiplication.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_subtraction.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_subtraction.worker.js
new file mode 100644
index 0000000000..f8b9a5c9fb
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_subtraction.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f16_matrix_subtraction.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_vector_multiplication.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_vector_multiplication.worker.js
new file mode 100644
index 0000000000..d15ae4e874
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_matrix_vector_multiplication.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f16_matrix_vector_multiplication.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_multiplication.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_multiplication.worker.js
new file mode 100644
index 0000000000..07a20c242c
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_multiplication.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f16_multiplication.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_remainder.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_remainder.worker.js
new file mode 100644
index 0000000000..2062f2f6c2
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_remainder.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f16_remainder.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_subtraction.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_subtraction.worker.js
new file mode 100644
index 0000000000..0812e2596a
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f16_subtraction.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f16_subtraction.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_addition.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_addition.worker.js
new file mode 100644
index 0000000000..6a4e856781
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_addition.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f32_addition.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_comparison.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_comparison.worker.js
new file mode 100644
index 0000000000..24be70b2b1
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_comparison.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f32_comparison.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_division.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_division.worker.js
new file mode 100644
index 0000000000..c4c529c8f4
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_division.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f32_division.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_addition.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_addition.worker.js
new file mode 100644
index 0000000000..f1782f5375
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_addition.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f32_matrix_addition.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_matrix_multiplication.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_matrix_multiplication.worker.js
new file mode 100644
index 0000000000..039780dcae
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_matrix_multiplication.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f32_matrix_matrix_multiplication.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_scalar_multiplication.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_scalar_multiplication.worker.js
new file mode 100644
index 0000000000..4438ac0342
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_scalar_multiplication.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f32_matrix_scalar_multiplication.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_subtraction.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_subtraction.worker.js
new file mode 100644
index 0000000000..02f57adfac
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_subtraction.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f32_matrix_subtraction.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_vector_multiplication.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_vector_multiplication.worker.js
new file mode 100644
index 0000000000..ddb363aaa4
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_matrix_vector_multiplication.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f32_matrix_vector_multiplication.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_multiplication.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_multiplication.worker.js
new file mode 100644
index 0000000000..7fec7f76d5
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_multiplication.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f32_multiplication.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_remainder.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_remainder.worker.js
new file mode 100644
index 0000000000..05b5a3c79f
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_remainder.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f32_remainder.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_subtraction.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_subtraction.worker.js
new file mode 100644
index 0000000000..c227a5eab5
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/f32_subtraction.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/f32_subtraction.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/i32_arithmetic.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/i32_arithmetic.worker.js
new file mode 100644
index 0000000000..9cb5320d76
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/i32_arithmetic.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/i32_arithmetic.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/i32_comparison.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/i32_comparison.worker.js
new file mode 100644
index 0000000000..54b62bca25
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/i32_comparison.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/i32_comparison.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/u32_arithmetic.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/u32_arithmetic.worker.js
new file mode 100644
index 0000000000..a630ff22b3
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/u32_arithmetic.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/u32_arithmetic.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/u32_comparison.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/u32_comparison.worker.js
new file mode 100644
index 0000000000..f554e8aa26
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/expression/binary/u32_comparison.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../../shader/execution/expression/binary/u32_comparison.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);