summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/mozilla/tests/webgpu/webgpu/api/operation/rendering/depth.spec.js
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/mozilla/tests/webgpu/webgpu/api/operation/rendering/depth.spec.js')
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/webgpu/api/operation/rendering/depth.spec.js9
1 files changed, 2 insertions, 7 deletions
diff --git a/testing/web-platform/mozilla/tests/webgpu/webgpu/api/operation/rendering/depth.spec.js b/testing/web-platform/mozilla/tests/webgpu/webgpu/api/operation/rendering/depth.spec.js
index 12c88f8dcd..19008f0850 100644
--- a/testing/web-platform/mozilla/tests/webgpu/webgpu/api/operation/rendering/depth.spec.js
+++ b/testing/web-platform/mozilla/tests/webgpu/webgpu/api/operation/rendering/depth.spec.js
@@ -467,13 +467,8 @@ fn((t) => {
@vertex fn main(
@builtin(vertex_index) VertexIndex : u32,
@builtin(instance_index) InstanceIndex : u32) -> Output {
- // TODO: remove workaround for Tint unary array access broke
- var zv : array<vec2<f32>, 4> = array<vec2<f32>, 4>(
- vec2<f32>(0.2, 0.2),
- vec2<f32>(0.3, 0.3),
- vec2<f32>(-0.1, -0.1),
- vec2<f32>(1.1, 1.1));
- let z : f32 = zv[InstanceIndex].x;
+ let zv = array(0.2, 0.3, -0.1, 1.1);
+ let z = zv[InstanceIndex];
var output : Output;
output.Position = vec4<f32>(0.5, 0.5, z, 1.0);