summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/mozilla/tests/webgpu/webgpu/shader/execution/zero_init.spec.js
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/mozilla/tests/webgpu/webgpu/shader/execution/zero_init.spec.js')
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/webgpu/shader/execution/zero_init.spec.js4
1 files changed, 4 insertions, 0 deletions
diff --git a/testing/web-platform/mozilla/tests/webgpu/webgpu/shader/execution/zero_init.spec.js b/testing/web-platform/mozilla/tests/webgpu/webgpu/shader/execution/zero_init.spec.js
index c7b21d5699..fe0c3cbe29 100644
--- a/testing/web-platform/mozilla/tests/webgpu/webgpu/shader/execution/zero_init.spec.js
+++ b/testing/web-platform/mozilla/tests/webgpu/webgpu/shader/execution/zero_init.spec.js
@@ -107,6 +107,10 @@ expandWithParams(function* (p) {
[true, false] :
[false]) {
for (const scalarType of supportedScalarTypes({ isAtomic, ...p })) {
+ // Fewer subcases: supportedScalarTypes was expanded to include f16
+ // but that may take too much time. It would require more complex code.
+ if (scalarType === 'f16') continue;
+
// Fewer subcases: For nested types, skip atomic u32 and non-atomic i32.
if (p._containerDepth > 0) {
if (scalarType === 'u32' && isAtomic) continue;