summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/CSS2/css1/c5502-mrgn-r-001-ref.xht
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/css/CSS2/css1/c5502-mrgn-r-001-ref.xht')
-rw-r--r--testing/web-platform/tests/css/CSS2/css1/c5502-mrgn-r-001-ref.xht68
1 files changed, 68 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/CSS2/css1/c5502-mrgn-r-001-ref.xht b/testing/web-platform/tests/css/CSS2/css1/c5502-mrgn-r-001-ref.xht
new file mode 100644
index 0000000000..79afce9051
--- /dev/null
+++ b/testing/web-platform/tests/css/CSS2/css1/c5502-mrgn-r-001-ref.xht
@@ -0,0 +1,68 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
+
+<html xmlns="http://www.w3.org/1999/xhtml">
+
+ <head>
+
+ <title>CSS Reftest Reference</title>
+
+ <link rel="author" title="GĂ©rard Talbot" href="http://www.gtalbot.org/BrowserBugsSection/css21testsuite/" />
+
+ <style type="text/css"><![CDATA[
+ p
+ {
+ color: navy;
+ margin: 0;
+ }
+
+ div.control
+ {
+ border: black solid medium;
+ margin: 1.25em;
+ width: 12.5em;
+ }
+
+ div.control div {height: 1.25em;}
+
+ div.a
+ {
+ border-left: yellow solid 8.75em;
+ border-right: orange solid 2.5em;
+ }
+
+ div.aa {border-right: teal solid 1.25em;}
+
+ div.b
+ {
+ border-left: aqua solid 6.25em;
+ border-right: orange solid 2.5em;
+ }
+
+ div.bb
+ {
+ border-left: teal solid 1.25em;
+ border-right: yellow solid 2.5em;
+ }
+ ]]>
+ </style>
+
+ </head>
+
+ <body>
+
+ <p>The following two diagrams should look identical.</p>
+
+ <div class="control">
+ <div class="a"><div class="aa"></div></div>
+ <div class="b"><div class="bb"></div></div>
+ <div class="a"><div class="aa"></div></div>
+ </div>
+
+ <div class="control">
+ <div class="a"><div class="aa"></div></div>
+ <div class="b"><div class="bb"></div></div>
+ <div class="a"><div class="aa"></div></div>
+ </div>
+
+ </body>
+</html>