summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/CSS2/css1/c5502-mrgn-r-001.xht
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/css/CSS2/css1/c5502-mrgn-r-001.xht')
-rw-r--r--testing/web-platform/tests/css/CSS2/css1/c5502-mrgn-r-001.xht49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/CSS2/css1/c5502-mrgn-r-001.xht b/testing/web-platform/tests/css/CSS2/css1/c5502-mrgn-r-001.xht
new file mode 100644
index 0000000000..8436101036
--- /dev/null
+++ b/testing/web-platform/tests/css/CSS2/css1/c5502-mrgn-r-001.xht
@@ -0,0 +1,49 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
+<html xmlns="http://www.w3.org/1999/xhtml">
+ <head>
+ <title>CSS Test: margin-right</title>
+ <meta name="flags" content="ahem" />
+ <link rel="help" href="http://www.w3.org/TR/REC-CSS1#margin-right"/>
+ <link rel="author" title="CSS1 Test Suite Contributors" href="http://www.w3.org/Style/CSS/Test/CSS1/current/tsack.html"/>
+ <link rel="author" title="Ian Hickson" href="mailto:ian@hixie.ch"/>
+ <link rel="reviewer" title="GĂ©rard Talbot" href="http://www.gtalbot.org/BrowserBugsSection/css21testsuite/" /> <!-- 2012-03-29 -->
+ <link rel="match" href="c5502-mrgn-r-001-ref.xht" />
+
+ <link rel="stylesheet" type="text/css" href="/fonts/ahem.css" />
+ <style type="text/css"><![CDATA[
+ div.control { margin: 1.25em; }
+ p.criteria { color: navy; }
+ p, ul, li { margin: 0; padding: 0; list-style: none; }
+
+ div.test { border: solid black; width: 10em; background-color: orange; font: 1.25em/1 Ahem; color: teal; margin: 1em; }
+ ul.test, li.test { margin-right: 2em; text-align: right; }
+ li.test { background-color: aqua; }
+ ul.test { background-color: yellow; }
+
+ .control { border: solid; width: 12.5em; background: red; }
+ .control div { border-style: none solid; height: 1.25em; }
+ .control .a { border-color: red orange red yellow; border-width: 0 2.5em 0 8.75em; }
+ .control .aa { border-color: red teal red red; border-width: 0 1.25em 0 0; }
+ .control .b { border-color: red orange red aqua; border-width: 0 2.5em 0 6.25em; }
+ .control .bb { border-color: red yellow red teal; border-width: 0 2.5em 0 1.25em; }
+
+ ]]></style>
+ <link rel="help" href="http://www.w3.org/TR/CSS21/box.html#margin-properties" title="8.3 Margin properties: 'margin-top', 'margin-right', 'margin-bottom', 'margin-left', and 'margin'"/>
+ <link rel="help" href="http://www.w3.org/TR/CSS21/box.html#border-properties" title="8.5 Border properties"/>
+ </head>
+ <body>
+ <p class="criteria">The following two diagrams should look identical.</p>
+ <div class="test">
+ <ul class="test">
+ <li>-</li>
+ <li class="test">-</li>
+ <li>-</li>
+ </ul>
+ </div>
+ <div class="control">
+ <div class="a"><div class="aa"></div></div>
+ <div class="b"><div class="bb"></div></div>
+ <div class="a"><div class="aa"></div></div>
+ </div>
+ </body>
+</html>