summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/css-tables
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/css/css-tables')
-rw-r--r--testing/web-platform/tests/css/css-tables/crashtests/caption-repaint-crash.html19
-rw-r--r--testing/web-platform/tests/css/css-tables/table-cell-inline-size-box-sizing-quirks-ref.html15
-rw-r--r--testing/web-platform/tests/css/css-tables/table-cell-inline-size-box-sizing-quirks.html19
-rw-r--r--testing/web-platform/tests/css/css-tables/tentative/table-rows-with-zero-columns.html62
4 files changed, 115 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/css-tables/crashtests/caption-repaint-crash.html b/testing/web-platform/tests/css/css-tables/crashtests/caption-repaint-crash.html
new file mode 100644
index 0000000000..6a024d0c1d
--- /dev/null
+++ b/testing/web-platform/tests/css/css-tables/crashtests/caption-repaint-crash.html
@@ -0,0 +1,19 @@
+<style>
+*:defined {
+ outline: currentColor dashed;
+}
+*:read-write {
+ animation: kf 200ms ease-out 16384 alternate-reverse backwards
+}
+@keyframes kf {
+ 20% {
+ clip-path: polygon(1px 0.75em, 128px 100%)
+ }
+}
+</style>
+<script>
+document.addEventListener("DOMContentLoaded", () => {
+ a.createCaption()
+})
+</script>
+<table id="a" contenteditable="true" align="left">
diff --git a/testing/web-platform/tests/css/css-tables/table-cell-inline-size-box-sizing-quirks-ref.html b/testing/web-platform/tests/css/css-tables/table-cell-inline-size-box-sizing-quirks-ref.html
new file mode 100644
index 0000000000..4b97b4499b
--- /dev/null
+++ b/testing/web-platform/tests/css/css-tables/table-cell-inline-size-box-sizing-quirks-ref.html
@@ -0,0 +1,15 @@
+<!doctype html>
+<title>CSS Test Reference</title>
+<style>
+ td {
+ width: 50px;
+ padding: 10px;
+ border: 1px solid black;
+ box-sizing: border-box;
+ }
+</style>
+<table>
+ <tr>
+ <td>A</td>
+ </tr>
+</table>
diff --git a/testing/web-platform/tests/css/css-tables/table-cell-inline-size-box-sizing-quirks.html b/testing/web-platform/tests/css/css-tables/table-cell-inline-size-box-sizing-quirks.html
new file mode 100644
index 0000000000..a59a0672e9
--- /dev/null
+++ b/testing/web-platform/tests/css/css-tables/table-cell-inline-size-box-sizing-quirks.html
@@ -0,0 +1,19 @@
+<!~quirks>
+<link rel="author" title="Emilio Cobos Álvarez" href="mailto:emilio@crisal.io">
+<link rel="author" title="Mozilla" href="https://mozilla.org">
+<link rel="help" href="https://quirks.spec.whatwg.org/#the-table-cell-height-box-sizing-quirk">
+<link rel="match" href="table-cell-inline-size-box-sizing-quirks-ref.html">
+<title>Table cell box-sizing quirk doesn't force inline-axis to be content-box</title>
+<style>
+ td {
+ width: 50px;
+ padding: 10px;
+ border: 1px solid black;
+ box-sizing: border-box;
+ }
+</style>
+<table>
+ <tr>
+ <td>A</td>
+ </tr>
+</table>
diff --git a/testing/web-platform/tests/css/css-tables/tentative/table-rows-with-zero-columns.html b/testing/web-platform/tests/css/css-tables/tentative/table-rows-with-zero-columns.html
new file mode 100644
index 0000000000..da9e0098a7
--- /dev/null
+++ b/testing/web-platform/tests/css/css-tables/tentative/table-rows-with-zero-columns.html
@@ -0,0 +1,62 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<title>CSS Test: size of table rows when the table has no columns</title>
+<link rel="author" title="Oriol Brufau" href="mailto:obrufau@igalia.com">
+<link rel="help" href="https://drafts.csswg.org/css-tables-3/">
+<link rel="help" href="https://github.com/w3c/csswg-drafts/issues/10132">
+<meta name="assert" content="If a table has rows but no columns, the rows are as wide as the inner width of the table.">
+
+<style>
+#tests table {
+ box-sizing: border-box;
+ width: 60px;
+ height: 60px;
+}
+</style>
+
+<div id="log"></div>
+
+<main id="tests">
+ <table cellspacing="0">
+ <tr data-expected-width="60" data-expected-height="60"></tr>
+ </table>
+
+ <table cellspacing="0">
+ <tr data-expected-width="60" data-expected-height="30"></tr>
+ <tr data-expected-width="60" data-expected-height="30"></tr>
+ </table>
+
+ <table cellspacing="10">
+ <tr data-expected-width="60" data-expected-height="40"></tr>
+ </table>
+
+ <table cellspacing="10">
+ <tr data-expected-width="60" data-expected-height="15"></tr>
+ <tr data-expected-width="60" data-expected-height="15"></tr>
+ </table>
+
+ <table cellspacing="0" border="5">
+ <tr data-expected-width="50" data-expected-height="50"></tr>
+ </table>
+
+ <table cellspacing="0" border="5">
+ <tr data-expected-width="50" data-expected-height="25"></tr>
+ <tr data-expected-width="50" data-expected-height="25"></tr>
+ </table>
+
+ <table cellspacing="10" border="5">
+ <tr data-expected-width="50" data-expected-height="30"></tr>
+ </table>
+
+ <table cellspacing="10" border="5">
+ <tr data-expected-width="50" data-expected-height="10"></tr>
+ <tr data-expected-width="50" data-expected-height="10"></tr>
+ </table>
+</main>
+
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script src="/resources/check-layout-th.js"></script>
+<script>
+checkLayout("tr");
+</script>