summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/css-writing-modes/forms/checkbox-appearance-native-vertical-lr-baseline.optional.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/css/css-writing-modes/forms/checkbox-appearance-native-vertical-lr-baseline.optional.html')
-rw-r--r--testing/web-platform/tests/css/css-writing-modes/forms/checkbox-appearance-native-vertical-lr-baseline.optional.html29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/css-writing-modes/forms/checkbox-appearance-native-vertical-lr-baseline.optional.html b/testing/web-platform/tests/css/css-writing-modes/forms/checkbox-appearance-native-vertical-lr-baseline.optional.html
new file mode 100644
index 0000000000..377a8e8785
--- /dev/null
+++ b/testing/web-platform/tests/css/css-writing-modes/forms/checkbox-appearance-native-vertical-lr-baseline.optional.html
@@ -0,0 +1,29 @@
+<!DOCTYPE html>
+<link rel="author" title="Aditya Keerthi" href="https://github.com/pxlcoder">
+<link rel="help" href="https://html.spec.whatwg.org/#checkbox-state-(type=checkbox)">
+<link rel="help" href="https://drafts.csswg.org/css-writing-modes-4/#block-flow">
+<title>Test baseline alignment of checkboxes in vertical-lr writing mode.</title>
+<meta charset="utf-8">
+<link rel="match" href="checkbox-appearance-native-vertical-lr-baseline.optional-ref.html">
+<style>
+
+label {
+ color: red;
+ background-color: red;
+ margin-top: -30px;
+}
+
+</style>
+<p>The checkbox should be center-aligned with the label it since text is non-alphabetic.</p>
+<div style="writing-mode: vertical-lr">
+ <input type="checkbox" id="checkbox" checked>
+ <label for="checkbox">こんにちわ</label>
+</div>
+
+<br>
+
+<p>The checkbox should be left-aligned with the label text since it has text-orientation sideways.</p>
+<div style="writing-mode: vertical-lr; text-orientation: sideways;">
+ <input type="checkbox" id="checkbox" checked>
+ <label for="checkbox">Baseline</label>
+</div>