summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/dom/nodes/Node-mutation-adoptNode.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/dom/nodes/Node-mutation-adoptNode.html')
-rw-r--r--testing/web-platform/tests/dom/nodes/Node-mutation-adoptNode.html23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/web-platform/tests/dom/nodes/Node-mutation-adoptNode.html b/testing/web-platform/tests/dom/nodes/Node-mutation-adoptNode.html
new file mode 100644
index 0000000000..9c9594c07b
--- /dev/null
+++ b/testing/web-platform/tests/dom/nodes/Node-mutation-adoptNode.html
@@ -0,0 +1,23 @@
+<!DOCTYPE html>
+<meta charset=utf-8>
+<title>Node-manipulation-adopted</title>
+<link rel=help href="https://dom.spec.whatwg.org/#dom-domimplementation-createhtmldocument">
+<link rel=help href="https://dom.spec.whatwg.org/#mutation-algorithms">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<div id="log"></div>
+<script>
+"use strict";
+
+test(() => {
+ const old = document.implementation.createHTMLDocument("");
+ const div = old.createElement("div");
+ div.appendChild(old.createTextNode("text"));
+ assert_equals(div.ownerDocument, old);
+ assert_equals(div.firstChild.ownerDocument, old);
+ document.body.appendChild(div);
+ assert_equals(div.ownerDocument, document);
+ assert_equals(div.firstChild.ownerDocument, document);
+}, "simple append of foreign div with text");
+
+</script>