summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/rendering/the-details-element/summary-display-list-item-001.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/html/rendering/the-details-element/summary-display-list-item-001.html')
-rw-r--r--testing/web-platform/tests/html/rendering/the-details-element/summary-display-list-item-001.html34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/rendering/the-details-element/summary-display-list-item-001.html b/testing/web-platform/tests/html/rendering/the-details-element/summary-display-list-item-001.html
new file mode 100644
index 0000000000..8b94f10f27
--- /dev/null
+++ b/testing/web-platform/tests/html/rendering/the-details-element/summary-display-list-item-001.html
@@ -0,0 +1,34 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<title>CSS Test: summary with 'display: list-item'</title>
+<link rel="author" title="Oriol Brufau" href="mailto:obrufau@igalia.com">
+<link rel="match" href="summary-display-list-item-001-ref.html">
+<link rel="help" href="https://html.spec.whatwg.org/multipage/rendering.html#the-details-and-summary-elements">
+<meta name="assert" content="Checks that styling a <summary> with 'display: list-item' has no effect since it should already be a list item by default.">
+<style>
+summary {
+ display: list-item;
+}
+details {
+ margin-left: 50px;
+}
+.inside {
+ list-style-position: inside;
+}
+</style>
+<details>
+ <summary>summary</summary>
+ content
+</details>
+<details>
+ <summary class="inside">summary</summary>
+ content
+</details>
+<details open>
+ <summary>summary</summary>
+ content
+</details>
+<details open>
+ <summary class="inside">summary</summary>
+ content
+</details>