summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/rendering/the-details-element/summary-display-list-item-002.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/html/rendering/the-details-element/summary-display-list-item-002.html')
-rw-r--r--testing/web-platform/tests/html/rendering/the-details-element/summary-display-list-item-002.html23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/rendering/the-details-element/summary-display-list-item-002.html b/testing/web-platform/tests/html/rendering/the-details-element/summary-display-list-item-002.html
new file mode 100644
index 0000000000..ee32997009
--- /dev/null
+++ b/testing/web-platform/tests/html/rendering/the-details-element/summary-display-list-item-002.html
@@ -0,0 +1,23 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<title>CSS Test: summary with 'display: list-item' and flex children</title>
+<link rel="author" title="Cameron McCormack" href="mailto:heycam@apple.com">
+<link rel="author" title="Sergio Villar Senin" href="mailto:svillar@igalia.com">
+<link rel="match" href="summary-display-list-item-002-ref.html">
+<link rel="help" href="https://html.spec.whatwg.org/multipage/rendering.html#the-details-and-summary-elements">
+<style>
+summary {
+ display: list-item;
+ list-style-type: none;
+}
+/* WebKit does not support list-style-type:none yet */
+summary::-webkit-details-marker { display: none; }
+</style>
+<details style="width: 100px;">
+ <summary>
+ <div style="display: flex; justify-content: space-between;">
+ <div>AAA</div>
+ <div>BBB</div>
+ </div>
+ </summary>
+</details>