summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/rendering/the-details-element/summary-text-decoration.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/html/rendering/the-details-element/summary-text-decoration.html')
-rw-r--r--testing/web-platform/tests/html/rendering/the-details-element/summary-text-decoration.html11
1 files changed, 11 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/rendering/the-details-element/summary-text-decoration.html b/testing/web-platform/tests/html/rendering/the-details-element/summary-text-decoration.html
new file mode 100644
index 0000000000..80bbd44c46
--- /dev/null
+++ b/testing/web-platform/tests/html/rendering/the-details-element/summary-text-decoration.html
@@ -0,0 +1,11 @@
+<!doctype html>
+<title>Rendering of summary element with text-decoration</title>
+<link rel="match" href="summary-text-decoration-ref.html">
+<link rel="help" href="https://html.spec.whatwg.org/multipage/rendering.html#the-details-and-summary-elements">
+<meta name="assert" content="Checks that text-decoration applies to rendered summary element.">
+<style>
+ summary { text-decoration: underline; }
+</style>
+<details>
+ <summary>This text should be underlined.</summary>
+</details>