summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/rendering
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/html/rendering')
-rw-r--r--testing/web-platform/tests/html/rendering/non-replaced-elements/form-controls/resets.html1
-rw-r--r--testing/web-platform/tests/html/rendering/widgets/button-layout/display-none-or-contents-ref.html3
-rw-r--r--testing/web-platform/tests/html/rendering/widgets/button-layout/display-none-or-contents.html12
3 files changed, 16 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/rendering/non-replaced-elements/form-controls/resets.html b/testing/web-platform/tests/html/rendering/non-replaced-elements/form-controls/resets.html
index db21188ee3..1a17aeac2d 100644
--- a/testing/web-platform/tests/html/rendering/non-replaced-elements/form-controls/resets.html
+++ b/testing/web-platform/tests/html/rendering/non-replaced-elements/form-controls/resets.html
@@ -50,6 +50,7 @@ input:not([type=image i], [type=range i], [type=checkbox i], [type=radio i]) {
}
input[type=hidden i] { display: none !important; }
marquee {
+ overflow: hidden;
text-align: initial;
}
table { display: table; box-sizing: border-box; }
diff --git a/testing/web-platform/tests/html/rendering/widgets/button-layout/display-none-or-contents-ref.html b/testing/web-platform/tests/html/rendering/widgets/button-layout/display-none-or-contents-ref.html
new file mode 100644
index 0000000000..c20a3065e4
--- /dev/null
+++ b/testing/web-platform/tests/html/rendering/widgets/button-layout/display-none-or-contents-ref.html
@@ -0,0 +1,3 @@
+<!DOCTYPE html>
+<title>button (in button layout) with display: none/contents</title>
+2 \ No newline at end of file
diff --git a/testing/web-platform/tests/html/rendering/widgets/button-layout/display-none-or-contents.html b/testing/web-platform/tests/html/rendering/widgets/button-layout/display-none-or-contents.html
new file mode 100644
index 0000000000..8f0ad3ab29
--- /dev/null
+++ b/testing/web-platform/tests/html/rendering/widgets/button-layout/display-none-or-contents.html
@@ -0,0 +1,12 @@
+<!DOCTYPE html>
+<title>button (in button layout) with display: none/contents</title>
+<link rel=match href=display-none-or-contents-ref.html>
+<link rel=help href=https://html.spec.whatwg.org/multipage/rendering.html#button-layout-2>
+<style>
+#none{ display: none}
+#contents { display: contents; font: initial }
+</style>
+<!-- Button layout should not impact "display: none" or "display: contents" on button elements -->
+<!-- https://github.com/whatwg/html/pull/10244 -->
+<button id=none>1</button>
+<button id=contents>2</button> \ No newline at end of file