summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/syntax/parsing/adoption_agency_check_the_end_tag_name.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/html/syntax/parsing/adoption_agency_check_the_end_tag_name.html')
-rw-r--r--testing/web-platform/tests/html/syntax/parsing/adoption_agency_check_the_end_tag_name.html20
1 files changed, 20 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/syntax/parsing/adoption_agency_check_the_end_tag_name.html b/testing/web-platform/tests/html/syntax/parsing/adoption_agency_check_the_end_tag_name.html
new file mode 100644
index 0000000000..f5d49dd45f
--- /dev/null
+++ b/testing/web-platform/tests/html/syntax/parsing/adoption_agency_check_the_end_tag_name.html
@@ -0,0 +1,20 @@
+<!DOCTYPE html>
+<title>The adoption agency algorithm should check the end tag's name</title>
+<link rel="author" href="mailto:n4ag3a2sh1i@gmail.com">
+<link rel="help" href="https://html.spec.whatwg.org/multipage/parsing.html#adoption-agency-algorithm">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+
+
+<script>
+'use strict';
+
+// This is a regression test for https://crbug.com/1217523.
+test(() => {
+ const wrapper = document.createElement('div');
+ const html = '<code some-attribute=""><div><code><code><code><code></code></code></code></code></div></code>';
+ wrapper.innerHTML = html;
+ assert_equals(wrapper.innerHTML, html);
+}, 'The algorithm should not reparent properly nested tags');
+
+</script>