summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/syntax/parsing/meta-inhead-insertion-mode.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/html/syntax/parsing/meta-inhead-insertion-mode.html')
-rw-r--r--testing/web-platform/tests/html/syntax/parsing/meta-inhead-insertion-mode.html15
1 files changed, 15 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/syntax/parsing/meta-inhead-insertion-mode.html b/testing/web-platform/tests/html/syntax/parsing/meta-inhead-insertion-mode.html
new file mode 100644
index 0000000000..4317e4eb14
--- /dev/null
+++ b/testing/web-platform/tests/html/syntax/parsing/meta-inhead-insertion-mode.html
@@ -0,0 +1,15 @@
+<!DOCTYPE html>
+<html>
+<head>
+<title>Encoding specified in the "charset" attribute should have precedence over "content" attribute.</title>
+<meta http-equiv="Content-Type" content="text/html; charset=koi8-r" charset="iso-8859-15">
+<link rel="help" href="https://html.spec.whatwg.org/multipage/parsing.html#parsing-main-inhead">
+<script src=/resources/testharness.js></script>
+<script src=/resources/testharnessreport.js></script>
+<script>
+test(function () {
+ assert_equals(document.characterSet, "ISO-8859-15");
+}, "Encoding specified in the 'charset' attribute should have precedence over 'content' attribute.");
+</script>
+</body>
+</html>