summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/user-activation/activation-trigger-keyboard-enter.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/html/user-activation/activation-trigger-keyboard-enter.html')
-rw-r--r--testing/web-platform/tests/html/user-activation/activation-trigger-keyboard-enter.html47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/user-activation/activation-trigger-keyboard-enter.html b/testing/web-platform/tests/html/user-activation/activation-trigger-keyboard-enter.html
new file mode 100644
index 0000000000..be32d999b1
--- /dev/null
+++ b/testing/web-platform/tests/html/user-activation/activation-trigger-keyboard-enter.html
@@ -0,0 +1,47 @@
+<!DOCTYPE html>
+<html>
+<head>
+ <link rel="help" href="https://html.spec.whatwg.org/multipage/interaction.html#activation-triggering-input-event">
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <script src="/resources/testdriver.js"></script>
+ <script src="/resources/testdriver-vendor.js"></script>
+ <script src="resources/utils.js"></script>
+</head>
+<body onload="runTests()">
+ <h1>Test for keyboard activation trigger for ENTER key</h1>
+ <p>Tests user activation from a ENTER keyboard event.</p>
+ <input type="text" autofocus />
+ <ol id="instructions">
+ <li>Press ENTER key.
+ </ol>
+ <script>
+ function runTests() {
+ promise_test(async () => {
+ const ENTER_KEY = '\uE007';
+
+ let keydown_event = getEvent('keydown');
+ let keypress_event = getEvent('keypress');
+ let keyup_event = getEvent('keyup');
+
+ await test_driver.send_keys(document.body, ENTER_KEY);
+
+ await keydown_event;
+ let consumed = await consumeTransientActivation();
+ assert_true(consumed,
+ "ENTER keydown event should result in activation");
+
+ await keypress_event;
+ consumed = await consumeTransientActivation();
+ assert_false(consumed,
+ "ENTER keypress should have no activation after keydown consumption");
+
+ await keyup_event;
+ consumed = await consumeTransientActivation();
+ assert_false(consumed,
+ "ENTER keyup should have no activation after keydown consumption");
+ }, "Activation through ENTER keyboard event");
+ }
+ </script>
+</body>
+</html>