summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/interfaces/storage.idl
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/interfaces/storage.idl')
-rw-r--r--testing/web-platform/tests/interfaces/storage.idl25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/web-platform/tests/interfaces/storage.idl b/testing/web-platform/tests/interfaces/storage.idl
new file mode 100644
index 0000000000..d47e37c40e
--- /dev/null
+++ b/testing/web-platform/tests/interfaces/storage.idl
@@ -0,0 +1,25 @@
+// GENERATED CONTENT - DO NOT EDIT
+// Content was automatically extracted by Reffy into webref
+// (https://github.com/w3c/webref)
+// Source: Storage Standard (https://storage.spec.whatwg.org/)
+
+[SecureContext]
+interface mixin NavigatorStorage {
+ [SameObject] readonly attribute StorageManager storage;
+};
+Navigator includes NavigatorStorage;
+WorkerNavigator includes NavigatorStorage;
+
+[SecureContext,
+ Exposed=(Window,Worker)]
+interface StorageManager {
+ Promise<boolean> persisted();
+ [Exposed=Window] Promise<boolean> persist();
+
+ Promise<StorageEstimate> estimate();
+};
+
+dictionary StorageEstimate {
+ unsigned long long usage;
+ unsigned long long quota;
+};