summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/interfaces/urlpattern.idl
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/interfaces/urlpattern.idl')
-rw-r--r--testing/web-platform/tests/interfaces/urlpattern.idl63
1 files changed, 63 insertions, 0 deletions
diff --git a/testing/web-platform/tests/interfaces/urlpattern.idl b/testing/web-platform/tests/interfaces/urlpattern.idl
new file mode 100644
index 0000000000..ca9fb979d2
--- /dev/null
+++ b/testing/web-platform/tests/interfaces/urlpattern.idl
@@ -0,0 +1,63 @@
+// GENERATED CONTENT - DO NOT EDIT
+// Content was automatically extracted by Reffy into webref
+// (https://github.com/w3c/webref)
+// Source: URL Pattern Standard (https://urlpattern.spec.whatwg.org/)
+
+typedef (USVString or URLPatternInit) URLPatternInput;
+
+[Exposed=(Window,Worker)]
+interface URLPattern {
+ constructor(URLPatternInput input, USVString baseURL, optional URLPatternOptions options = {});
+ constructor(optional URLPatternInput input = {}, optional URLPatternOptions options = {});
+
+ boolean test(optional URLPatternInput input = {}, optional USVString baseURL);
+
+ URLPatternResult? exec(optional URLPatternInput input = {}, optional USVString baseURL);
+
+ readonly attribute USVString protocol;
+ readonly attribute USVString username;
+ readonly attribute USVString password;
+ readonly attribute USVString hostname;
+ readonly attribute USVString port;
+ readonly attribute USVString pathname;
+ readonly attribute USVString search;
+ readonly attribute USVString hash;
+
+ readonly attribute boolean hasRegExpGroups;
+};
+
+dictionary URLPatternInit {
+ USVString protocol;
+ USVString username;
+ USVString password;
+ USVString hostname;
+ USVString port;
+ USVString pathname;
+ USVString search;
+ USVString hash;
+ USVString baseURL;
+};
+
+dictionary URLPatternOptions {
+ boolean ignoreCase = false;
+};
+
+dictionary URLPatternResult {
+ sequence<URLPatternInput> inputs;
+
+ URLPatternComponentResult protocol;
+ URLPatternComponentResult username;
+ URLPatternComponentResult password;
+ URLPatternComponentResult hostname;
+ URLPatternComponentResult port;
+ URLPatternComponentResult pathname;
+ URLPatternComponentResult search;
+ URLPatternComponentResult hash;
+};
+
+dictionary URLPatternComponentResult {
+ USVString input;
+ record<USVString, (USVString or undefined)> groups;
+};
+
+typedef (USVString or URLPatternInit or URLPattern) URLPatternCompatible;