summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/interfaces/websockets.idl
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/interfaces/websockets.idl')
-rw-r--r--testing/web-platform/tests/interfaces/websockets.idl48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/web-platform/tests/interfaces/websockets.idl b/testing/web-platform/tests/interfaces/websockets.idl
new file mode 100644
index 0000000000..6ff16790b0
--- /dev/null
+++ b/testing/web-platform/tests/interfaces/websockets.idl
@@ -0,0 +1,48 @@
+// GENERATED CONTENT - DO NOT EDIT
+// Content was automatically extracted by Reffy into webref
+// (https://github.com/w3c/webref)
+// Source: WebSockets Standard (https://websockets.spec.whatwg.org/)
+
+enum BinaryType { "blob", "arraybuffer" };
+
+[Exposed=(Window,Worker)]
+interface WebSocket : EventTarget {
+ constructor(USVString url, optional (DOMString or sequence<DOMString>) protocols = []);
+ readonly attribute USVString url;
+
+ // ready state
+ const unsigned short CONNECTING = 0;
+ const unsigned short OPEN = 1;
+ const unsigned short CLOSING = 2;
+ const unsigned short CLOSED = 3;
+ readonly attribute unsigned short readyState;
+ readonly attribute unsigned long long bufferedAmount;
+
+ // networking
+ attribute EventHandler onopen;
+ attribute EventHandler onerror;
+ attribute EventHandler onclose;
+ readonly attribute DOMString extensions;
+ readonly attribute DOMString protocol;
+ undefined close(optional [Clamp] unsigned short code, optional USVString reason);
+
+ // messaging
+ attribute EventHandler onmessage;
+ attribute BinaryType binaryType;
+ undefined send((BufferSource or Blob or USVString) data);
+};
+
+[Exposed=(Window,Worker)]
+interface CloseEvent : Event {
+ constructor(DOMString type, optional CloseEventInit eventInitDict = {});
+
+ readonly attribute boolean wasClean;
+ readonly attribute unsigned short code;
+ readonly attribute USVString reason;
+};
+
+dictionary CloseEventInit : EventInit {
+ boolean wasClean = false;
+ unsigned short code = 0;
+ USVString reason = "";
+};