summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/tools/third_party/pywebsocket3/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/tools/third_party/pywebsocket3/setup.py')
-rwxr-xr-xtesting/web-platform/tests/tools/third_party/pywebsocket3/setup.py15
1 files changed, 8 insertions, 7 deletions
diff --git a/testing/web-platform/tests/tools/third_party/pywebsocket3/setup.py b/testing/web-platform/tests/tools/third_party/pywebsocket3/setup.py
index 12c60d8617..ab9a24a3e7 100755
--- a/testing/web-platform/tests/tools/third_party/pywebsocket3/setup.py
+++ b/testing/web-platform/tests/tools/third_party/pywebsocket3/setup.py
@@ -28,7 +28,8 @@
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-"""Set up script for mod_pywebsocket.
+
+"""Set up script for pywebsocket3.
"""
from __future__ import absolute_import
@@ -36,7 +37,7 @@ from __future__ import print_function
from setuptools import setup, Extension
import sys
-_PACKAGE_NAME = 'mod_pywebsocket'
+_PACKAGE_NAME = 'pywebsocket3'
# Build and use a C++ extension for faster masking. SWIG is required.
_USE_FAST_MASKING = False
@@ -49,8 +50,8 @@ if sys.hexversion < 0x020700f0:
if _USE_FAST_MASKING:
setup(ext_modules=[
- Extension('mod_pywebsocket/_fast_masking',
- ['mod_pywebsocket/fast_masking.i'],
+ Extension('pywebsocket3/_fast_masking',
+ ['pywebsocket3/fast_masking.i'],
swig_opts=['-c++'])
])
@@ -58,16 +59,16 @@ setup(
author='Yuzo Fujishima',
author_email='yuzo@chromium.org',
description='Standalone WebSocket Server for testing purposes.',
- long_description=('mod_pywebsocket is a standalone server for '
+ long_description=('pywebsocket3 is a standalone server for '
'the WebSocket Protocol (RFC 6455). '
- 'See mod_pywebsocket/__init__.py for more detail.'),
+ 'See pywebsocket3/__init__.py for more detail.'),
license='See LICENSE',
name=_PACKAGE_NAME,
packages=[_PACKAGE_NAME, _PACKAGE_NAME + '.handshake'],
python_requires='>=2.7',
install_requires=['six'],
url='https://github.com/GoogleChromeLabs/pywebsocket3',
- version='3.0.2',
+ version='4.0.2',
)
# vi:sts=4 sw=4 et