summaryrefslogtreecommitdiffstats
path: root/third_party/python/pylru/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/python/pylru/setup.py')
-rw-r--r--third_party/python/pylru/setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/third_party/python/pylru/setup.py b/third_party/python/pylru/setup.py
new file mode 100644
index 0000000000..66d441ca94
--- /dev/null
+++ b/third_party/python/pylru/setup.py
@@ -0,0 +1,23 @@
+from distutils.core import setup
+
+setup(
+ name = "pylru",
+ version = "1.0.9",
+ py_modules=['pylru'],
+ description = "A least recently used (LRU) cache implementation",
+ author = "Jay Hutchinson",
+ author_email = "jlhutch+pylru@gmail.com",
+ url = "https://github.com/jlhutch/pylru",
+ classifiers = [
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: GNU General Public License (GPL)",
+ "Operating System :: OS Independent",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ ],
+ long_description=open('README.txt').read())
+
+