summaryrefslogtreecommitdiffstats
path: root/third_party/rust/anstyle/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/anstyle/Cargo.toml')
-rw-r--r--third_party/rust/anstyle/Cargo.toml85
1 files changed, 85 insertions, 0 deletions
diff --git a/third_party/rust/anstyle/Cargo.toml b/third_party/rust/anstyle/Cargo.toml
new file mode 100644
index 0000000000..2772726c76
--- /dev/null
+++ b/third_party/rust/anstyle/Cargo.toml
@@ -0,0 +1,85 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.70.0"
+name = "anstyle"
+version = "1.0.3"
+include = [
+ "build.rs",
+ "src/**/*",
+ "Cargo.toml",
+ "Cargo.lock",
+ "LICENSE*",
+ "README.md",
+ "benches/**/*",
+ "examples/**/*",
+]
+description = "ANSI text styling"
+homepage = "https://github.com/rust-cli/anstyle"
+readme = "README.md"
+keywords = [
+ "ansi",
+ "terminal",
+ "color",
+ "no_std",
+]
+categories = ["command-line-interface"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-cli/anstyle.git"
+
+[package.metadata.release]
+tag-prefix = ""
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+min = 1
+replace = "{{version}}"
+search = "Unreleased"
+
+[[package.metadata.release.pre-release-replacements]]
+exactly = 1
+file = "CHANGELOG.md"
+replace = "...{{tag_name}}"
+search = '\.\.\.HEAD'
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+min = 1
+replace = "{{date}}"
+search = "ReleaseDate"
+
+[[package.metadata.release.pre-release-replacements]]
+exactly = 1
+file = "CHANGELOG.md"
+replace = """
+<!-- next-header -->
+## [Unreleased] - ReleaseDate
+"""
+search = "<!-- next-header -->"
+
+[[package.metadata.release.pre-release-replacements]]
+exactly = 1
+file = "CHANGELOG.md"
+replace = """
+<!-- next-url -->
+[Unreleased]: https://github.com/rust-cli/anstyle/compare/{{tag_name}}...HEAD"""
+search = "<!-- next-url -->"
+
+[dependencies]
+
+[dev-dependencies.lexopt]
+version = "0.3.0"
+
+[features]
+default = ["std"]
+std = []