summaryrefslogtreecommitdiffstats
path: root/third_party/rust/bumpalo/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/bumpalo/Cargo.toml11
1 files changed, 9 insertions, 2 deletions
diff --git a/third_party/rust/bumpalo/Cargo.toml b/third_party/rust/bumpalo/Cargo.toml
index 02ec679c2b..53fc06bb97 100644
--- a/third_party/rust/bumpalo/Cargo.toml
+++ b/third_party/rust/bumpalo/Cargo.toml
@@ -11,8 +11,9 @@
[package]
edition = "2021"
+rust-version = "1.73.0"
name = "bumpalo"
-version = "3.12.0"
+version = "3.15.4"
authors = ["Nick Fitzgerald <fitzgen@gmail.com>"]
exclude = [
"/.github/*",
@@ -29,7 +30,7 @@ categories = [
"rust-patterns",
"no-std",
]
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
repository = "https://github.com/fitzgen/bumpalo"
[package.metadata.docs.rs]
@@ -50,6 +51,11 @@ path = "benches/benches.rs"
harness = false
required-features = ["collections"]
+[dependencies.allocator-api2]
+version = "0.2.8"
+optional = true
+default-features = false
+
[dev-dependencies.criterion]
version = "0.3.6"
@@ -64,3 +70,4 @@ allocator_api = []
boxed = []
collections = []
default = []
+std = []