summaryrefslogtreecommitdiffstats
path: root/third_party/rust/core-foundation/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/core-foundation/Cargo.toml')
-rw-r--r--third_party/rust/core-foundation/Cargo.toml19
1 files changed, 15 insertions, 4 deletions
diff --git a/third_party/rust/core-foundation/Cargo.toml b/third_party/rust/core-foundation/Cargo.toml
index 7ea9578156..47cf3f2640 100644
--- a/third_party/rust/core-foundation/Cargo.toml
+++ b/third_party/rust/core-foundation/Cargo.toml
@@ -10,23 +10,32 @@
# See Cargo.toml.orig for the original contents.
[package]
+edition = "2018"
name = "core-foundation"
-version = "0.9.3"
+version = "0.9.4"
authors = ["The Servo Project Developers"]
description = "Bindings to Core Foundation for macOS"
homepage = "https://github.com/servo/core-foundation-rs"
-keywords = ["macos", "framework", "objc"]
+keywords = [
+ "macos",
+ "framework",
+ "objc",
+]
categories = ["os::macos-apis"]
-license = "MIT / Apache-2.0"
+license = "MIT OR Apache-2.0"
repository = "https://github.com/servo/core-foundation-rs"
+
[package.metadata.docs.rs]
+all-features = true
default-target = "x86_64-apple-darwin"
+
[dependencies.chrono]
version = "0.4"
optional = true
[dependencies.core-foundation-sys]
-version = "0.8.3"
+version = "0.8.6"
+default-features = false
[dependencies.libc]
version = "0.2"
@@ -36,6 +45,8 @@ version = "0.5"
optional = true
[features]
+default = ["link"]
+link = ["core-foundation-sys/link"]
mac_os_10_7_support = ["core-foundation-sys/mac_os_10_7_support"]
mac_os_10_8_features = ["core-foundation-sys/mac_os_10_8_features"]
with-chrono = ["chrono"]