summaryrefslogtreecommitdiffstats
path: root/third_party/rust/diplomat-runtime/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/diplomat-runtime/Cargo.toml')
-rw-r--r--third_party/rust/diplomat-runtime/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/third_party/rust/diplomat-runtime/Cargo.toml b/third_party/rust/diplomat-runtime/Cargo.toml
new file mode 100644
index 0000000000..99c0e4c6ed
--- /dev/null
+++ b/third_party/rust/diplomat-runtime/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "diplomat-runtime"
+version = "0.7.0"
+authors = [
+ "Shadaj Laddad <shadaj@users.noreply.github.com>",
+ "Manish Goregaokar <manishsmail@gmail.com>",
+ "Quinn Okabayashi <QnnOkabayashi@users.noreply.github.com>",
+]
+description = "Common runtime utilities used by diplomat codegen"
+documentation = "https://docs.rs/diplomat_core/"
+keywords = [
+ "ffi",
+ "codegen",
+]
+categories = ["development-tools"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-diplomat/diplomat"
+
+[lib]
+path = "src/lib.rs"
+
+[dependencies.log]
+version = "0.4"
+optional = true