summaryrefslogtreecommitdiffstats
path: root/third_party/rust/glean-core/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/glean-core/Cargo.toml')
-rw-r--r--third_party/rust/glean-core/Cargo.toml130
1 files changed, 130 insertions, 0 deletions
diff --git a/third_party/rust/glean-core/Cargo.toml b/third_party/rust/glean-core/Cargo.toml
new file mode 100644
index 0000000000..44c159051d
--- /dev/null
+++ b/third_party/rust/glean-core/Cargo.toml
@@ -0,0 +1,130 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.66"
+name = "glean-core"
+version = "57.0.0"
+authors = [
+ "Jan-Erik Rediger <jrediger@mozilla.com>",
+ "The Glean Team <glean-team@mozilla.com>",
+]
+include = [
+ "/README.md",
+ "/LICENSE",
+ "/src",
+ "/examples",
+ "/tests",
+ "/Cargo.toml",
+ "/uniffi.toml",
+ "/build.rs",
+]
+description = "A modern Telemetry library"
+readme = "README.md"
+keywords = ["telemetry"]
+license = "MPL-2.0"
+repository = "https://github.com/mozilla/glean"
+
+[package.metadata.glean]
+glean-parser = "11.0.1"
+
+[dependencies.bincode]
+version = "1.2.1"
+
+[dependencies.chrono]
+version = "0.4.10"
+features = ["serde"]
+
+[dependencies.crossbeam-channel]
+version = "0.5"
+
+[dependencies.env_logger]
+version = "0.10.0"
+optional = true
+default-features = false
+
+[dependencies.flate2]
+version = "1.0.19"
+
+[dependencies.log]
+version = "0.4.8"
+
+[dependencies.once_cell]
+version = "1.18.0"
+
+[dependencies.rkv]
+version = "0.19.0"
+features = ["lmdb"]
+default-features = false
+
+[dependencies.serde]
+version = "1.0.104"
+features = ["derive"]
+
+[dependencies.serde_json]
+version = "1.0.44"
+
+[dependencies.thiserror]
+version = "1.0.4"
+
+[dependencies.time]
+version = "0.1.40"
+
+[dependencies.uniffi]
+version = "0.25.2"
+default-features = false
+
+[dependencies.uuid]
+version = "1.0"
+features = ["v4"]
+
+[dependencies.zeitstempel]
+version = "0.1.0"
+
+[dev-dependencies.ctor]
+version = "0.2.2"
+
+[dev-dependencies.env_logger]
+version = "0.10.0"
+features = ["humantime"]
+default-features = false
+
+[dev-dependencies.iso8601]
+version = "0.4"
+
+[dev-dependencies.tempfile]
+version = "3.8.0"
+
+[build-dependencies.uniffi]
+version = "0.25.2"
+features = ["build"]
+default-features = false
+
+[features]
+enable_env_logger = ["env_logger"]
+preinit_million_queue = []
+
+[target."cfg(target_os = \"android\")".dependencies.android_logger]
+version = "0.12.0"
+default-features = false
+
+[target."cfg(target_os = \"ios\")".dependencies.oslog]
+version = "0.1.0"
+features = ["logger"]
+default-features = false
+
+[badges.circle-ci]
+branch = "main"
+repository = "mozilla/glean"
+
+[badges.maintenance]
+status = "actively-developed"