summaryrefslogtreecommitdiffstats
path: root/third_party/rust/indexmap/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/indexmap/Cargo.toml')
-rw-r--r--third_party/rust/indexmap/Cargo.toml108
1 files changed, 108 insertions, 0 deletions
diff --git a/third_party/rust/indexmap/Cargo.toml b/third_party/rust/indexmap/Cargo.toml
new file mode 100644
index 0000000000..28f3618f01
--- /dev/null
+++ b/third_party/rust/indexmap/Cargo.toml
@@ -0,0 +1,108 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.56"
+name = "indexmap"
+version = "1.9.3"
+description = "A hash table with consistent order and fast iteration."
+documentation = "https://docs.rs/indexmap/"
+readme = "README.md"
+keywords = [
+ "hashmap",
+ "no_std",
+]
+categories = [
+ "data-structures",
+ "no-std",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/bluss/indexmap"
+
+[package.metadata.release]
+no-dev-version = true
+tag-name = "{{version}}"
+
+[package.metadata.docs.rs]
+features = [
+ "arbitrary",
+ "quickcheck",
+ "serde-1",
+ "rayon",
+]
+
+[profile.bench]
+debug = true
+
+[lib]
+bench = false
+
+[dependencies.arbitrary]
+version = "1.0"
+optional = true
+default-features = false
+
+[dependencies.hashbrown]
+version = "0.12"
+features = ["raw"]
+default-features = false
+
+[dependencies.quickcheck]
+version = "1.0"
+optional = true
+default-features = false
+
+[dependencies.rayon]
+version = "1.4.1"
+optional = true
+
+[dependencies.rustc-rayon]
+version = "0.5"
+optional = true
+package = "rustc-rayon"
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+default-features = false
+
+[dev-dependencies.fnv]
+version = "1.0"
+
+[dev-dependencies.fxhash]
+version = "0.2.1"
+
+[dev-dependencies.itertools]
+version = "0.10"
+
+[dev-dependencies.lazy_static]
+version = "1.3"
+
+[dev-dependencies.quickcheck]
+version = "1.0"
+default-features = false
+
+[dev-dependencies.rand]
+version = "0.8"
+features = ["small_rng"]
+
+[dev-dependencies.serde_derive]
+version = "1.0"
+
+[build-dependencies.autocfg]
+version = "1"
+
+[features]
+serde-1 = ["serde"]
+std = []
+test_debug = []
+test_low_transition_point = []