summaryrefslogtreecommitdiffstats
path: root/third_party/rust/khronos-egl/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/khronos-egl/shell.nix')
-rw-r--r--third_party/rust/khronos-egl/shell.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/third_party/rust/khronos-egl/shell.nix b/third_party/rust/khronos-egl/shell.nix
new file mode 100644
index 0000000000..bf6c1364df
--- /dev/null
+++ b/third_party/rust/khronos-egl/shell.nix
@@ -0,0 +1,10 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+pkgs.mkShell {
+ buildInputs = [
+ pkgs.gcc
+ pkgs.libGL
+ pkgs.pkg-config
+ ];
+ LD_LIBRARY_PATH="${pkgs.libGL}/lib";
+} \ No newline at end of file