summaryrefslogtreecommitdiffstats
path: root/third_party/rust/litrs/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/litrs/Cargo.toml')
-rw-r--r--third_party/rust/litrs/Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/third_party/rust/litrs/Cargo.toml b/third_party/rust/litrs/Cargo.toml
new file mode 100644
index 0000000000..6e65403490
--- /dev/null
+++ b/third_party/rust/litrs/Cargo.toml
@@ -0,0 +1,51 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.54"
+name = "litrs"
+version = "0.4.1"
+authors = ["Lukas Kalbertodt <lukas.kalbertodt@gmail.com>"]
+exclude = [".github"]
+description = """
+Parse and inspect Rust literals (i.e. tokens in the Rust programming language
+representing fixed values). Particularly useful for proc macros, but can also
+be used outside of a proc-macro context.
+"""
+documentation = "https://docs.rs/litrs/"
+readme = "README.md"
+keywords = [
+ "literal",
+ "parsing",
+ "proc-macro",
+ "type",
+ "procedural",
+]
+categories = [
+ "development-tools::procedural-macro-helpers",
+ "parser-implementations",
+ "development-tools::build-utils",
+]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/LukasKalbertodt/litrs/"
+
+[dependencies.proc-macro2]
+version = "1"
+optional = true
+
+[dependencies.unicode-xid]
+version = "0.2.4"
+optional = true
+
+[features]
+check_suffix = ["unicode-xid"]
+default = ["proc-macro2"]