summaryrefslogtreecommitdiffstats
path: root/third_party/rust/mach2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/mach2/Cargo.toml')
-rw-r--r--third_party/rust/mach2/Cargo.toml49
1 files changed, 49 insertions, 0 deletions
diff --git a/third_party/rust/mach2/Cargo.toml b/third_party/rust/mach2/Cargo.toml
new file mode 100644
index 0000000000..422e53094c
--- /dev/null
+++ b/third_party/rust/mach2/Cargo.toml
@@ -0,0 +1,49 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2015"
+name = "mach2"
+version = "0.4.1"
+include = [
+ "src/**/*",
+ "LICENSE-*",
+ "README.md",
+]
+description = "A Rust interface to the user-space API of the Mach 3.0 kernel that underlies OSX."
+readme = "README.md"
+keywords = [
+ "kernel",
+ "macos",
+ "darwin",
+]
+categories = [
+ "api-bindings",
+ "external-ffi-bindings",
+ "no-std",
+ "os",
+]
+license = "BSD-2-Clause OR MIT OR Apache-2.0"
+repository = "https://github.com/JohnTitor/mach2"
+
+[package.metadata.docs.rs]
+default-target = "x86_64-apple-darwin"
+
+[features]
+default = []
+unstable = []
+
+[target."cfg(any(target_os = \"macos\", target_os = \"ios\"))".dependencies.libc]
+version = "0.2"
+default-features = false
+
+[badges.maintenance]
+status = "passively-maintained"