summaryrefslogtreecommitdiffstats
path: root/third_party/rust/metal/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/metal/Cargo.toml')
-rw-r--r--third_party/rust/metal/Cargo.toml144
1 files changed, 144 insertions, 0 deletions
diff --git a/third_party/rust/metal/Cargo.toml b/third_party/rust/metal/Cargo.toml
new file mode 100644
index 0000000000..a81b535fd0
--- /dev/null
+++ b/third_party/rust/metal/Cargo.toml
@@ -0,0 +1,144 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "metal"
+version = "0.27.0"
+authors = ["gfx-rs developers"]
+exclude = [
+ "guide/**/*",
+ "examples/texture/**/*",
+ "tests/**/*",
+ "Cargo.lock",
+ "target/**/*",
+]
+description = "Rust bindings for Metal"
+homepage = "https://github.com/gfx-rs/metal-rs"
+documentation = "https://docs.rs/crate/metal"
+readme = "README.md"
+keywords = [
+ "metal",
+ "graphics",
+ "bindings",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/gfx-rs/metal-rs"
+
+[package.metadata.docs.rs]
+default-target = "x86_64-apple-darwin"
+
+[[example]]
+name = "window"
+
+[[example]]
+name = "headless-render"
+
+[[example]]
+name = "library"
+
+[[example]]
+name = "raytracing"
+
+[[example]]
+name = "reflection"
+
+[[example]]
+name = "caps"
+
+[[example]]
+name = "argument-buffer"
+
+[[example]]
+name = "bindless"
+
+[[example]]
+name = "circle"
+path = "examples/circle/main.rs"
+
+[[example]]
+name = "compute"
+path = "examples/compute/main.rs"
+
+[[example]]
+name = "mps"
+required-features = ["mps"]
+
+[[example]]
+name = "embedded-lib"
+path = "examples/compute/embedded-lib.rs"
+
+[[example]]
+name = "compute-argument-buffer"
+path = "examples/compute/compute-argument-buffer.rs"
+
+[[example]]
+name = "bind"
+
+[[example]]
+name = "events"
+required-features = ["dispatch"]
+
+[[example]]
+name = "fence"
+
+[dependencies.bitflags]
+version = "2"
+
+[dependencies.block]
+version = "0.1.6"
+
+[dependencies.core-graphics-types]
+version = "0.1"
+
+[dependencies.dispatch]
+version = "0.2"
+optional = true
+
+[dependencies.foreign-types]
+version = "0.5"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.objc]
+version = "0.2.4"
+features = ["objc_exception"]
+
+[dependencies.paste]
+version = "1"
+
+[dev-dependencies.cocoa]
+version = "0.24.0"
+
+[dev-dependencies.cty]
+version = "0.2.1"
+
+[dev-dependencies.glam]
+version = "0.22"
+
+[dev-dependencies.png]
+version = "0.17"
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[dev-dependencies.sema]
+version = "0.1.4"
+
+[dev-dependencies.winit]
+version = "0.27"
+
+[features]
+default = ["link"]
+link = []
+mps = []
+private = []