summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-common/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/neqo-common/Cargo.toml28
1 files changed, 8 insertions, 20 deletions
diff --git a/third_party/rust/neqo-common/Cargo.toml b/third_party/rust/neqo-common/Cargo.toml
index dc5bed385f..90b254c888 100644
--- a/third_party/rust/neqo-common/Cargo.toml
+++ b/third_party/rust/neqo-common/Cargo.toml
@@ -13,7 +13,7 @@
edition = "2021"
rust-version = "1.74.0"
name = "neqo-common"
-version = "0.7.2"
+version = "0.7.5"
authors = ["The Neqo Authors <necko@mozilla.com>"]
build = "build.rs"
homepage = "https://github.com/mozilla/neqo/"
@@ -23,6 +23,10 @@ repository = "https://github.com/mozilla/neqo/"
[lib]
bench = false
+[[bench]]
+name = "timer"
+harness = false
+
[dependencies.enum-map]
version = "2.7"
default-features = false
@@ -39,26 +43,14 @@ default-features = false
version = "0.12"
default-features = false
-[dependencies.quinn-udp]
-git = "https://github.com/quinn-rs/quinn/"
-rev = "a947962131aba8a6521253d03cc948b20098a2d6"
-optional = true
-
[dependencies.time]
version = "0.3"
features = ["formatting"]
default-features = false
-[dependencies.tokio]
-version = "1"
-features = [
- "net",
- "time",
- "macros",
- "rt",
- "rt-multi-thread",
-]
-optional = true
+[dev-dependencies.criterion]
+version = "0.5"
+features = ["html_reports"]
default-features = false
[dev-dependencies.test-fixture]
@@ -66,10 +58,6 @@ path = "../test-fixture"
[features]
ci = []
-udp = [
- "dep:quinn-udp",
- "dep:tokio",
-]
[target."cfg(windows)".dependencies.winapi]
version = "0.3"