summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-crypto/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/neqo-crypto/Cargo.toml')
-rw-r--r--third_party/rust/neqo-crypto/Cargo.toml40
1 files changed, 28 insertions, 12 deletions
diff --git a/third_party/rust/neqo-crypto/Cargo.toml b/third_party/rust/neqo-crypto/Cargo.toml
index 73c1fcb364..499921e531 100644
--- a/third_party/rust/neqo-crypto/Cargo.toml
+++ b/third_party/rust/neqo-crypto/Cargo.toml
@@ -10,16 +10,21 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
-rust-version = "1.70.0"
+edition = "2021"
+rust-version = "1.74.0"
name = "neqo-crypto"
-version = "0.7.0"
-authors = ["Martin Thomson <mt@lowentropy.net>"]
+version = "0.7.2"
+authors = ["The Neqo Authors <necko@mozilla.com>"]
build = "build.rs"
+homepage = "https://github.com/mozilla/neqo/"
license = "MIT OR Apache-2.0"
+repository = "https://github.com/mozilla/neqo/"
+
+[lib]
+bench = false
[dependencies.log]
-version = "~0.4.17"
+version = "0.4"
default-features = false
[dependencies.neqo-common]
@@ -28,21 +33,32 @@ path = "../neqo-common"
[dev-dependencies.test-fixture]
path = "../test-fixture"
-[build-dependencies]
-serde = "1.0.195"
-serde_derive = "1.0.195"
-toml = "0.5.11"
-
[build-dependencies.bindgen]
-version = "0.69.1"
+version = "0.69"
features = ["runtime"]
default-features = false
[build-dependencies.mozbuild]
version = "0.1"
optional = true
+default-features = false
+
+[build-dependencies.serde]
+version = "1.0"
+default-features = false
+
+[build-dependencies.serde_derive]
+version = "1.0"
+default-features = false
+
+[build-dependencies.toml]
+version = "0.5"
+default-features = false
[features]
-deny-warnings = []
fuzzing = []
gecko = ["mozbuild"]
+
+[lints.clippy.pedantic]
+level = "warn"
+priority = -1