summaryrefslogtreecommitdiffstats
path: root/third_party/rust/nss-gk-api/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/nss-gk-api/Cargo.toml')
-rw-r--r--third_party/rust/nss-gk-api/Cargo.toml54
1 files changed, 54 insertions, 0 deletions
diff --git a/third_party/rust/nss-gk-api/Cargo.toml b/third_party/rust/nss-gk-api/Cargo.toml
new file mode 100644
index 0000000000..c521bc7df6
--- /dev/null
+++ b/third_party/rust/nss-gk-api/Cargo.toml
@@ -0,0 +1,54 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.57.0"
+name = "nss-gk-api"
+version = "0.3.0"
+authors = [
+ "Martin Thomson <mt@lowentropy.net>",
+ "Andy Leiserson <aleiserson@mozilla.com>",
+ "John M. Schanck <jschanck@mozilla.com>",
+]
+description = "Gecko API for NSS"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/mozilla/nss-gk-api"
+
+[dependencies.once_cell]
+version = "1"
+
+[dependencies.pkcs11-bindings]
+version = ">= 0.1.3"
+
+[build-dependencies.bindgen]
+version = ">= 0.59.2"
+features = ["runtime"]
+default-features = false
+
+[build-dependencies.mozbuild]
+version = "0.1"
+optional = true
+
+[build-dependencies.serde]
+version = "1.0"
+
+[build-dependencies.serde_derive]
+version = "1.0"
+
+[build-dependencies.toml]
+version = "0.5"
+
+[features]
+default = ["deny-warnings"]
+deny-warnings = []
+gecko = ["mozbuild"]