summaryrefslogtreecommitdiffstats
path: root/third_party/rust/num-derive/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/num-derive/Cargo.toml')
-rw-r--r--third_party/rust/num-derive/Cargo.toml69
1 files changed, 69 insertions, 0 deletions
diff --git a/third_party/rust/num-derive/Cargo.toml b/third_party/rust/num-derive/Cargo.toml
new file mode 100644
index 0000000000..6ff605a52f
--- /dev/null
+++ b/third_party/rust/num-derive/Cargo.toml
@@ -0,0 +1,69 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.56.0"
+name = "num-derive"
+version = "0.4.0"
+authors = ["The Rust Project Developers"]
+exclude = [
+ "/bors.toml",
+ "/ci/*",
+ "/.github/*",
+]
+description = "Numeric syntax extensions"
+homepage = "https://github.com/rust-num/num-derive"
+documentation = "https://docs.rs/num-derive"
+readme = "README.md"
+keywords = [
+ "mathematics",
+ "numerics",
+]
+categories = ["science"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-num/num-derive"
+
+[lib]
+name = "num_derive"
+test = false
+proc-macro = true
+
+[[test]]
+name = "newtype-2015"
+edition = "2015"
+
+[[test]]
+name = "newtype-2018"
+edition = "2018"
+
+[[test]]
+name = "trivial-2015"
+edition = "2015"
+
+[[test]]
+name = "trivial-2018"
+edition = "2018"
+
+[dependencies.proc-macro2]
+version = "1"
+
+[dependencies.quote]
+version = "1"
+
+[dependencies.syn]
+version = "2.0.5"
+
+[dev-dependencies.num]
+version = "0.4"
+
+[dev-dependencies.num-traits]
+version = "0.2"